[Return]
Posting mode: Reply
Name
E-mail
Subject
Comment
File
Password(Password used for file deletion)
  • Supported file types are: GIF, JPG, PNG
  • Maximum file size allowed is 3072 KB.
  • Images greater than 250x250 pixels will be thumbnailed.
  • Read the rules and FAQ before posting.
  • このサイトについて - 翻訳
  • Blotter updated: 07/19/08


  • For future reference, check status.4chan.org for updates when the main site is unreachable.
    Flush your DNS cache and clear your hosts file.
    A news post will go up some time in the next 48-72 hours.

    File :1217820001.jpg-(144 KB, 1528x1950, glenda.jpg)
    144 KB Anonymous 08/03/08(Sun)23:20 No.1969086  
    Plan 9 thread.

    Posted from Plan 9.
    >> Anonymous 08/03/08(Sun)23:22 No.1969099
    People actually use Plan 9?
    >> Anonymous 08/03/08(Sun)23:23 No.1969106
    >>1969099
    More people use it than you think.
    >> Anonymous 08/03/08(Sun)23:24 No.1969107
    Can't download the iso, anyone have a working mirror?
    >> Anonymous 08/03/08(Sun)23:24 No.1969110
    >>1969099
    As a toy mostly. /g/ mostly just fucks around with it.
    >> Anonymous 08/03/08(Sun)23:25 No.1969123
    Plan 9: because linux has just gotten way too fucking easy.
    >> Anonymous 08/03/08(Sun)23:33 No.1969159
    pretty much all the tricks people do on the internet (e.g. "http") are attempts to do what plan 9 got right in the first place.
    >> Anonymous 08/03/08(Sun)23:33 No.1969160
    So, if you are considering trying out Plan 9, here's what you can do with it pretty simply:

    Basic web browsing via abaco or the links port.
    OpenSSH has been ported, the terminal is not fully compliant though.
    There are some usable IRC clients
    The system has a very good shell and all-in-one editor/file manager.
    I'm sure there's a ton more, but that's about as far as I've gotten in a day or two of work. I've gotten a decent minimal computing environment going, now I want to learn how to do the cool stuff that Plan 9 was designed for. I actually have it installed on two machines (qemu vms on separate hardware) so I should be able to get the networked CPU thing going on.
    >> Anonymous 08/03/08(Sun)23:35 No.1969169
    Seriously though why are any of you doing anything with this OS?? seriously what can it do that other can't???
    >> Anonymous 08/03/08(Sun)23:38 No.1969185
    Well, the stuff plan 9 can do that other OSes cant s pretty esoteric - it can be setup to treat a network of machines as a single platform, it isnt bound to any particular cpu or hard drive.

    I'm using it because its interesting, educational, and because it has ideas that may be useful to me in the software I'm working on. Trying to figure out how to organize and work with information in general is a diffucult thing and plan 9 actually as a lot of GREAT ideas about how to do it - a lot of which have been re-used by other oses.
    >> Anonymous 08/03/08(Sun)23:39 No.1969192
    >>1969169
    use an obfuscated and inherently crippled operating system that was supposed to be simple.
    >> Anonymous 08/03/08(Sun)23:39 No.1969194
    >>1969169
    learning purposes you up the arse windows or mac user
    >> Anonymous 08/03/08(Sun)23:40 No.1969201
    >>Plan 9
    >> Anonymous 08/03/08(Sun)23:59 No.1969290
    So, anyone out there want to install plan 9 and see how it works? Takes about an hour to setup inside a qemu virtual machine inside Ubuntu 8.04.
    >> Anonymous 08/04/08(Mon)00:00 No.1969297
    >>1969290
    I do, but the download stalls after like 5 seconds and I can't find a mirror. The only one I've found does the same shit.

    I even saved the shit from the plan9 thread yesterday.
    FUCK
    >> Anonymous 08/04/08(Mon)00:04 No.1969320
    >>1969185
    What ideas? There's UTF-8...that's all I can think of.
    >> Anonymous 08/04/08(Mon)00:05 No.1969323
    Maybe yesterday's plan9 thread has triggered a tidal wave of demand and the servers have died under the onslaught of plan9 downloaders.
    >> Anonymous 08/04/08(Mon)00:06 No.1969329
    >>1969323
    They must be running on Plan 9.
    :3
    >> Anonymous 08/04/08(Mon)00:12 No.1969360
    Has a webserver even been ported to Plan 9? lol. somebody musta got apache 1.x running on it or something, maybe its in contrib.
    >> Anonymous 08/04/08(Mon)00:12 No.1969362
    Plan 9 is great but glenda still scares the shit outa me.
    >> Anonymous 08/04/08(Mon)00:13 No.1969365
    >>1969185
    And when will those features actually be useful on other platforms???
    Unless you're making the stupid decision that plan9 is anything but an experiment by AT&T because they realized how fucked they were when they sold Unix. It's never smart to do mental masturbation that pertains to uslesness. Or to put your eggs in one basket thinking this is anything but a real hobby OS. I mean shit, I'd rather use Solaris than this.
    >> Anonymous 08/04/08(Mon)00:14 No.1969371
    >>1969365
    >Slowlaris
    >> Anonymous 08/04/08(Mon)00:16 No.1969378
    >>1969371
    I know, but I'd still use that shit over Plan(shit we sold unix lets make something to top it)9.
    >>1969290
    And how are those networking features going to come in play if you're fucking using it in a virtual machine.
    >> Anonymous 08/04/08(Mon)00:17 No.1969385
    >>1969365
    ZFS will be the future
    >> Anonymous 08/04/08(Mon)00:19 No.1969388
    The plan 9 filename namespace system has contributed a lot of stuff, for instance the /proc directory in linux. The concept of plumbing is actually one of the first implementations of the sorts of stuff that any modern desktop does in terms of knowing how to deal with multiple filetypes. The network-centric model has actually kind of sprung to life again in the form of cloud computing and various web 2.0 projects. I could go on, but thats a few things.
    >> SOLaris 10 !Xx5qkOA3Fw 08/04/08(Mon)00:20 No.1969391
         File :1217823605.jpg-(48 KB, 640x480, 1214931441764.jpg)
    48 KB
    >>1969371
    >> Anonymous 08/04/08(Mon)00:21 No.1969398
    >>1969388
    If you're going to credit these to Plan9 then go do some fucking research and get back to me.
    >> Anonymous 08/04/08(Mon)00:24 No.1969405
    I haven't used Plan 9 so I can't really say if it's good or not, but I do like the retarded bunny logo.
    >> Anonymous 08/04/08(Mon)00:26 No.1969410
    Well, EVERY SINGLE THING a computer can do can be credited to Charles Babbage as proved by Alan Turing and with the implementation described by von Neumann. Nothing can take exclusive credit for anything, and multics ALWAYS did it first. Plan 9 is still cool regardless of how you assign credit for innovations.
    >> Anonymous 08/04/08(Mon)00:28 No.1969423
    http://www.cl.cam.ac.uk/~mgk25/ucs/utf-8-history.txt
    which also explains why not much besides UTF-8 made it out of plan9: there were already lots of existing conflicting standards for all that shit.
    >> Anonymous 08/04/08(Mon)00:31 No.1969432
    >>1969410
    plan9 is in no way cool.
    >> Anonymous 08/04/08(Mon)00:38 No.1969461
    Nobody is saying that anyone should "switch to plan 9" or even spend a huge amount of time with it. It's interesting and fun, for some. I don't watch television or DVDs, I like to fuck around with computer shit as a hobby, and I think some of the stuff you learn is valuable. Actually, I've already learned some useful gnu/linux shit just because Plan 9 forces me to learn about stuff I would otherwise never know.

    Also, virtual machines can network just fine, to whoever was asking that...
    >> Anonymous 08/04/08(Mon)00:53 No.1969552
    Plan 9 is a MUCH, MUCH better videogame than Crysis, and it takes less hardware resources to run. Troll the gaemers, not people exploring interesting corners of the universe of free software.
    >> FAGGATRON_3000 !U0FKfqmRjs 08/04/08(Mon)01:00 No.1969581
    >>1969461


    GENTOO MAH BOI
    >> Anonymous 08/04/08(Mon)01:02 No.1969592
    I run Gentoo...it doesnt even begin to compare to what trying to figure out Plan 9 is like.

    Plan 9 is just enough like *nix to be really dangerous. For instance, the way 'inheritance' works on the system can really confuse you, because if you start your shells independently, stuff you do in one shell may not carry over into the other shell, because the other shell wont 'see' the stuff you did.
    >> Anonymous 08/04/08(Mon)01:07 No.1969617
    >>1969581

    HELL YEAH SON
    >> Anonymous 08/04/08(Mon)01:13 No.1969665
    >>1969581
    >>1969617

    Samefag.
    >> Anonymous 08/04/08(Mon)01:15 No.1969671
    >>1969360
    They run the Plan 9 Web site on a Plan 9 server, so it's got something. The site has a whole list of applications.
    >> Anonymous 08/04/08(Mon)01:16 No.1969675
    >>1969552

    Poorfag that can't run Crysis.
    >> Anonymous 08/04/08(Mon)01:16 No.1969682
    >>1969675

    That's not funny, my brother died that way.
    >> FAGGATRON_3000 !U0FKfqmRjs 08/04/08(Mon)01:20 No.1969714
    >>1969086

    God damn, this is probably the best mascot ever.
    >> Anonymous 08/04/08(Mon)01:25 No.1969737
    FUCK YEAH PLAN 9

    I'm installing this right now.
    >> Anonymous 08/04/08(Mon)01:28 No.1969751
    Of course can plan 9 can be a 'web server' - the whole point of plan 9 is that it doesnt even know the difference between being a 'web server' and ordinary file access, in many ways. Plan 9 systems can work with 'remote' files identically to local files. In linux terms, its sort of like extremely efficient automatic NFS connecting and mounting of multiple machines into a single namespace...sorta.
    >> Anonymous 08/04/08(Mon)01:38 No.1969773
    Plan 9 post install miniguide:
    1) spend some time learning a bit about how the rio window manager, acme editor/file manager, and rc shell work. the mouse commands are very different than a modern desktop os, very important, and not consistent between apps.
    2) for networking, you can enable it on-the-fly using the commands listed near the end of man ipconfig for dhcp setup, or use acme editor to edit the /rc/bin/termrc file and uncomment the dhcp lines, save and restart
    3) once you ahve networking, you need to
    9fs sources
    to get access to the 'repositories' of software. after doing 9fs sources with an active network, you can find tons of stuff in /n/sources/contrib directory on your system, which is linked to the repos. there is an index of what is available linked from the wiki, or just google plan 9 contrib index.
    >> Anonymous 08/04/08(Mon)01:38 No.1969775
    FUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUUCK
    Someone who has it upload it somewhere
    >> Anonymous 08/04/08(Mon)01:39 No.1969778
    Is there anywhere you can get a decent shell for Plan9?
    I tried the default "rc" shell, but it doesn't seem to understand that you shouldn't be able to backspace the whole screen away, among other things.
    >> Anonymous 08/04/08(Mon)01:40 No.1969783
    >>1969751
    no. sorry. thats retarded.
    >> Anonymous 08/04/08(Mon)01:42 No.1969789
    does the scroll wheel work?
    no?
    faggots.
    >> Anonymous 08/04/08(Mon)01:43 No.1969793
    >>1969775
    You can download it from the official site, dumbass.
    >> Anonymous 08/04/08(Mon)01:45 No.1969800
    >>1969778

    uh, you can enable various different terminal emulation, but its true that plan 9 has a lot of weird models for how the mouse / cursor will combine. being able to backspace the whole screen away is also regarded more as 'feature' than 'bug' in the plan 9 world. the cool thing about the shell is teh way you can use the 'plumb' and 'send' features from inside it.

    for instance, i got my networking enabled this way: i typed man ipconfig, then scrolled up to the 'sample commands' for basic dhcp. then i selected the first command with my left mouse button click and drag, then clicked in on the scroll wheel and chose 'send' and the command was executed at the command line in the shell. scroll back up, select command #2 the same way, send it the same way. a couple 'send' commands later, working network. avoided any possible typing mistakes, and more efficient than cut& paste.
    >> Anonymous 08/04/08(Mon)01:46 No.1969805
    >>1969773
    this caught my eye, because my name is rio... no I'm not a girl, no I'm not asian.
    >> Anonymous 08/04/08(Mon)01:48 No.1969811
         File :1217828893.png-(132 KB, 1280x800, 2008-08-04-054800_1280x800_scr(...).png)
    132 KB
    >>1969793
    No I can't.
    >> Anonymous 08/04/08(Mon)01:50 No.1969819
    making a mirrior at gs85.com/plan9/

    check on it in ~15-30 minutes

    gotta wait for wget to finish
    >> Anonymous 08/04/08(Mon)01:50 No.1969821
    >>1969805
    brasilian?
    >> Anonymous 08/04/08(Mon)01:51 No.1969826
    >>1969819
    thank you anonymous
    >> Anonymous 08/04/08(Mon)02:03 No.1969891
    >>1969819
    wget is finished

    enjoy faster download than the official site
    >> Anonymous 08/04/08(Mon)02:06 No.1969903
    >>1969891
    FUCK YEAH
    Got excited and started before it was done, but it is successfully downloaded now. I still don't know why I couldn't get it from the official site or mirror though.

    Will install in a VM very fucking soon.
    >> Anonymous 08/04/08(Mon)02:07 No.1969907
         File :1217830076.jpg-(470 KB, 1632x1224, plan9fyeah.jpg)
    470 KB
    PLAN 9 FROM BELL LABS

    INVADING YOUR HOME

    PLUMBING YOUR FILETYPES
    >> Anonymous 08/04/08(Mon)02:12 No.1969923
    God damn, why is their site so fucking slow?
    The link was fine actually, I just used the official one, and the mirrors with aria2, but the site, holy fuck.
    >> Anonymous 08/04/08(Mon)02:13 No.1969925
    I've had the best luck using qemu emulator in ubuntu to use Plan 9. In virtualbox, i never got the graphics working, and you really cant do much without Rio. I posted a ton of how-to guides yesterday, some of which are fucked up and kinda misleading because I was learning as I was going. Anyone who actually wants to get plan 9 setup ill be here in this thread all night...I actually have plan 9 running on TWO machines now...
    >> Anonymous 08/04/08(Mon)02:16 No.1969932
    I'm installing it in Qemu as we speak, I've got an nVidia 7300GS, what do I select for monitor type?
    >> Anonymous 08/04/08(Mon)02:25 No.1969951
    It should be noted that the cool stuff about Plan 9 is as follows:

    1) Its genuinely different than anything else, it can only be described as Unix on acid in an alternate reality, and really the only thing 'unix' about it is a few shell commands and the idea of the filesystem namespace as all-encompassing.
    2) The architecture has some nice ideas, and stuff like plumbing and special purpose filesystems like ftpfs and using the client/server model for as much possible. HOWEVER:

    The user interface is drastically out of step with current thinking, and to be honest its pretty bad. Its not as bad as it seems at first, when youre just like...wtfwtfwtfwtf, but its still pretty bad compared to any modern desktop. The cursor behavior will baffle you at first.

    Also obviously, application software is very patchy. There are some decent native apps for basic things and a fair number of ports from the general free software world, but its not like using a *nix - if you were thinking you could do gnome+openoffice, FUGGEDABOUT IT.

    Basically, using plan 9 is like going on a camping trip away from civilization to a beautiful place. The trip is an experience and worth doing, and you are missing the point if you complain that there's no running water and hot showers.
    >> Anonymous 08/04/08(Mon)02:27 No.1969957
    >>1969925
    maybe you should think about getting a job instead of wasting your parents electricity.
    >> Anonymous 08/04/08(Mon)02:28 No.1969959
    on qemu you just tell it vesa for graphics
    the default is xga, change it to vesa
    you can set the resolution like this, in terminal:

    aux/vga -m vesa -l 1024x768x8

    that gives you 1024x768 which is very reasonable
    >> Anonymous 08/04/08(Mon)02:29 No.1969961
    1969952
    >> Anonymous 08/04/08(Mon)02:42 No.1970011
         File :1217832169.png-(30 KB, 686x533, 2008-08-04-064233_686x533_scro(...).png)
    30 KB
    GODDAMN I CAN'T WAIT TO RICE THIS SHIT OUT
    >> Anonymous 08/04/08(Mon)02:46 No.1970026
    So
    Guys
    Im gunna install this on a virtualbox with 64mb of RAM, 8mb of video, and a 1gb hard drive.
    Will it run?
    >> Anonymous 08/04/08(Mon)02:49 No.1970044
    >>1970026
    The wiki says to use a 2GB disk, but mine is installing and overall I'm using 133 MB of RAM with my whole Lunix install running + firefox + qemu

    I think 64 MB is enough.
    >> Anonymous 08/04/08(Mon)02:55 No.1970072
    I installed Plan 9 on an old 466MHz Celeron box a month ago and didn't do anything with it.
    It's still in it's initial post-install state. No changes whatsoever.
    The main reason I haven't touched it is because there doesn't seem to be any documentation whatsoever.
    I couldn't even figure out how to start rio.
    If I could just get a browser or something up and running (even lynx would do) then I would have something to keep me occupied while I mess with shit.
    >> Anonymous 08/04/08(Mon)02:55 No.1970073
    The main reason i recommended more RAM is that a lot of the most useful software you are gonna need to compile locally via the contrib repository. Its easy to use, a few copy & paste terminal terminal commands is all, but compilan goes better with RAM.
    >> Anonymous 08/04/08(Mon)02:56 No.1970078
    >>1970044
    Im so gunna use this for my EEE.
    Not only will it befuddle thiefs, it'll make me look EXTRA geeky.
    :D
    >> Anonymous 08/04/08(Mon)03:01 No.1970104
    downloading now at 34KB/sec - slow

    this better be worth it
    >> Anonymous 08/04/08(Mon)03:02 No.1970109
    wow, you got plan 9 running on actual hardware? when you boot, have you tried logging in as user glenda? if taht doesnt start rio correctly, try doing aux/vga -m vesa -l 640x480x8, any graphics card ought to support low resa vesa mode right? then just do rio and i think it should start...if your graphcis are weird for some reason try aux/vga -m vesa -p to list available graphics modes.
    >> Anonymous 08/04/08(Mon)03:04 No.1970122
    >>1970104
    download it from gs85.com/plan9/ instead, much faster
    >> Anonymous 08/04/08(Mon)03:05 No.1970126
    >>1970104
    >this better be worth it
    If the thought of trying a new OS doesn't make you excited, then stop downloading and leave /g/.
    >> Anonymous 08/04/08(Mon)03:08 No.1970137
    >>1970122

    much better thanks
    >> Anonymous 08/04/08(Mon)03:08 No.1970141
    From the Wiki article it looks like Plan9 is POSIX compliant... so getting Linux apps ported to it would probably require much less effort than e.g. Linux to Windows.
    >> Anonymous 08/04/08(Mon)03:09 No.1970144
         File :1217833792.png-(19 KB, 1024x768, GAEMANinplan9.png)
    19 KB
    Multitasking arcade gaming in PLAN 9

    Over 9000 FPS, AFx32, AAx16
    >> Anonymous 08/04/08(Mon)03:10 No.1970147
    >>1970144
    HOLY SHIT
    >> Anonymous 08/04/08(Mon)03:11 No.1970152
         File :1217833883.png-(611 B, 99x81, 2008-08-04-071116_99x81_scrot.png)
    611 B
    >>1970144
    awesome
    >> Anonymous 08/04/08(Mon)03:11 No.1970153
    >>1970141

    Yeah that work is being done in contrib. For instance, you can actually build OpenSSH from the contrib repo and get it to run fine, and quite a few other things have been ported over also. I think its just lack of developers mostly that keeps it from having a full 'ports' library, although Im sure there are issues I dont understand.
    >> Anonymous 08/04/08(Mon)03:11 No.1970154
    >>1970141
    >when you boot, have you tried logging in as user glenda?
    Awesome. That worked. Thanks a lot.
    >> Anonymous 08/04/08(Mon)03:12 No.1970156
    >>1970154
    Now how do I get a browser on this thing?
    >> Anonymous 08/04/08(Mon)03:13 No.1970160
    >>1970156
    bind -b '#l0' /net
    bind -a '#I0' /net
    ip/ipconfig
    ndb/cs
    ndb/dns -r
    pull
    9fs sources
    cd /n/sources/contrib/quanstro/src/abaco
    mkdir /usr/glenda/tmp/abaco
    cp * /usr/glenda/tmp/abaco
    cd /usr/glenda/tmp/abaco
    webcookies
    webfs
    >> Anonymous 08/04/08(Mon)03:18 No.1970177
    >>1969959
    So, wait.
    when I first boot, select "install plan 9 from this disk"
    and it asks for my vga res
    then monitor type
    Do I do my preferred res and then vesa?
    >> Anonymous 08/04/08(Mon)03:19 No.1970180
    It doesn't seem to like USB mice.
    I guess I'm going to have to go digging through my attic...
    >> Anonymous 08/04/08(Mon)03:19 No.1970183
    >>1970177
    You can install by leaving those at their defaults.
    It'll just run at 640x480
    >> Anonymous 08/04/08(Mon)03:20 No.1970186
    >>1970183
    Can I change the res later?
    I'd prefer to be able to do shit.
    >> Anonymous 08/04/08(Mon)03:23 No.1970194
    >>1970156

    That gives you the 'abaco' browser which is the most advanced 'plan 9 native' browser -- its kind of slow and awkward, but it does have some cool shit once you get used to it.

    you can also build links with full vga graphics support and libraries for all image types. heres how you do that:
    [get networking started]

    9fs sources
    cp /n/sources/contrib/andrey/links.tgz /usr/glenda/tmp
    cd /usr/glenda/tmp
    tar xzf links.tgz
    cd links
    mk
    mk install

    takes awhile to build but its a pretty impressive browser all things considered.
    >> Anonymous 08/04/08(Mon)03:24 No.1970196
    >>1970177

    you have to choose 'vesa' rather than the default xga, but you can leave the res at 640x480x8 for the install and change later.
    >> Anonymous 08/04/08(Mon)03:25 No.1970199
         File :1217834744.jpg-(22 KB, 640x479, untitled.jpg)
    22 KB
    Is that a motherfucking CPU/RAM/Pagefile monitor?
    Jesus fuck
    >> Anonymous 08/04/08(Mon)03:25 No.1970201
    >>1970160

    those commands are missing the actual commands to build and install the browser! its missing the mk and mk install, and also another weird step involving copying a file

    an easier way to get abaco and lots of other stuff going:

    /n/sources/contrib/fgb/root/rc/bin/contrib/install fgb/contrib
    contrib/install fgb/links
    >> Anonymous 08/04/08(Mon)03:26 No.1970203
    >>1970196
    So, thats a yes you can change your res later if you selected xga and 640x480 on install?
    >> Anonymous 08/04/08(Mon)03:26 No.1970204
    >>1970199

    It's a lot more than that. Right click in it and you can customize it by adding in a ton of other monitors and removing stuff you dont want to use.
    >> Anonymous 08/04/08(Mon)03:27 No.1970207
    >>1970204
    AS;ODHYZX;C8YSHDUJZXC
    WHY DIDNT WINDOWS MOTHERFUCKING 95/98/2000/ME/XP/2K3/VISTA HAVE THIS SHIT
    LOOK AT THAT
    ITS LIKE 16BIT RAINMETER
    >> Anonymous 08/04/08(Mon)03:28 No.1970208
    >>1970201

    arg, that second line SHOULD be:

    contrib/install fgb/abaco

    grr im gonna spoil shit for people with sloppy typing. Also, missing commands from the end of other abaco install method are:

    mk
    cp passwd.6.font /lib/font/bit/lucidasans/
    mk install

    inside the abaco directory.
    >> Anonymous 08/04/08(Mon)03:31 No.1970211
    >>1970207
    THIS HAS GOT TO BE THE COOLEST FUCKING OS I HAVE EVER USED
    >> Anonymous 08/04/08(Mon)03:32 No.1970214
    >>1970160
    Could you briefly go over what each of these commands do, if possible?
    I'd like to learn, rather than just copying and pasting things.
    >> Anonymous 08/04/08(Mon)03:32 No.1970218
    >>1970208
    so, what would that be all at once?
    >> Anonymous 08/04/08(Mon)03:33 No.1970222
    minesweeper tutorial::

    [networking up]
    9fs sources
    /n/sources/contrib/fgb/root/rc/bin/contrib/install fgb/contrib
    contrib/install fgb/mines

    then start mines with /386/bin/games/mines

    note that if you already have contrib/install installed you can skip the line that sets it up. note that every new shell needs 9fs sources done separately, because of how the bind/mount system works with inheritance.
    >> Anonymous 08/04/08(Mon)03:34 No.1970224
    >>1970204
    This is beyond fucking awesome.
    >> Anonymous 08/04/08(Mon)03:36 No.1970230
    >>1970224
    Fucking hell I know
    Whats even more is its using less than 1/12th of 64mb of memory
    Im gunna finish installing this with virtualbox and then rerun it on a machine with 8mb of RAM and 1mb of video.
    >> Anonymous 08/04/08(Mon)03:40 No.1970247
    Sorry I'm kind of fragmented and flaky trying to copy and paste these commands, let me try to provide first a truly solid cut & paste template for networking + installing:

    get networking up [find these commands in man ipconfig]
    (note be very careful number/letterwise, ell-zero, eye-zero)
    bind -b '#l0' /net
    bind -a '#I0' /net
    ip/ipconfig
    ndb/cs
    ndb/dns -r

    add repositories and update system:

    9fs sources
    pull
    /n/sources/contrib/fgb/root/rc/bin/contrib/install fgb/contrib

    get abaco browser:
    install/contrib fgb/abaco

    start abaco browser:
    webcookies
    webfs
    abaco
    >> Anonymous 08/04/08(Mon)03:41 No.1970249
    Whenever a terminal fills up, the program stops until I scroll down.
    What's the deal?
    >> Anonymous 08/04/08(Mon)03:44 No.1970259
    once you have done
    9fs sources

    the /n/sources directory is just part of your filesystem and you can explore it as you wish. REMEMBER THAT YOU ARE ACTUALLY ACESSING A FILE SERVER when you do this. /n/sources is a REMOTE set of directories, so stuff that is in source or tarball form you can copy over to /usr/glenda/tmp to work with.

    there is a special selection of packages that can be installed with contrib/install that a particular maintainer has. thats what
    /n/sources/contrib/fgb/root/rc/bin/contrib/install fgb/contrib
    sets up
    this is how you build openssl and openssh if you want them, and provides an alternate way to install abaco rather than the other method listed earlier (that is split across two posts anyway)
    >> Anonymous 08/04/08(Mon)03:44 No.1970263
    >>1970249

    no, the program doesnt stop - it has run and produced its output, but the terminal does autoscroll you. there are a TON of other differences between plan9's GUI and what you are used to, the mouse in particular is used very differently. different software implements it differently.
    >> Anonymous 08/04/08(Mon)03:47 No.1970267
    Ok, so where's everybody at in terms of needing help:

    Graphics and resolutions up and OK?
    Networking up OK?
    software installation working OK?

    Note that the default path for glenda DOES NOT include a ton of stuff. there are a lot of commands available on your system that you have to type a FULL PATH to execute, especially once you start installing from contrib. for instace, a lot of the contrib/install packages get put in /386/bin or subdirectories thereof
    >> Anonymous 08/04/08(Mon)03:47 No.1970268
    >>1970267
    Is there a large manual for this or something I can use?
    >> Anonymous 08/04/08(Mon)03:49 No.1970275
    >>1970267
    How do you set resolution post-install?
    >> Anonymous 08/04/08(Mon)03:53 No.1970291
    >>1970275

    aux/vga -m vesa -l 1024x768x8

    will set you to vesa at that resolution. substitute 800x600x8 or 1280x1024x8 if you want to. maybe you can use x16 or x24 at the end too, depending on vid card and memory available, im not sure.
    >> Anonymous 08/04/08(Mon)03:54 No.1970295
         File :1217836486.png-(29 KB, 647x549, Untitled.png)
    29 KB
    Halp im stuck here. I don't know the where the dir is for the distribution.
    >> Anonymous 08/04/08(Mon)03:55 No.1970297
    POSTING FROM PLAN9 ON ANCIENT HARDWARE!
    FUCK YEAH!
    I absolutely love how everything starts out as a terminal, then switches over to graphical display when you start something that uses a GUI. It's a really neat concept, and it keeps everything uniform.
    Also, the graph is fucking awesome, the repository mounted on the main filesystem tree is fucking awesome, and Glenda is fucking awesome.
    I love this OS.
    >> Anonymous 08/04/08(Mon)03:56 No.1970306
         File :1217836612.png-(56 KB, 1024x768, acmeandfriends.png)
    56 KB
    >>1970268

    Glad you asked ! viewing documentation (of which there are about 10,000 pages of included) is easily done with the acme editor/file manager. screenshot related, i used acme to launch the pdf viewer showing the rc manual kind of in the middle background of the screen.

    (also note that the minesweeper game i started earlier i died on THE FIRST FUCKING SQUARE I CLICKED.)

    anyway, in acme, you can navigate around directories and launch file viewers just by clicking or selecting with the correct mouse button. uh, gimme sec and ill try to explain it a bit.

    there are a TON of docs in /sys/doc to look at.
    >> Anonymous 08/04/08(Mon)03:57 No.1970307
    They hurt her.

    About six years ago in Indiana, Carmen Winstead was pushed down a sewer opening by five girls in her school, trying to embarrass her in front of her school during a fire drill. When she didn't submerge, the police were called. They went down and brought up 17-year-old Carmen Winstead's body, with her neck broken from hitting the ladder, then the concrete at the bottom. The girls told everyone she fell... They believed them.

    FACT: About over 9000 months later, 16-year-old David Gregory read this post and didn't repost it. When he went to take a shower, he heard laughter, started freaking out, and ran to his computer to repost it. He said goodnight to his mom and went to sleep, but five hours later, his mom woke up in the middle of the night from a loud noise and David was gone. A few hours later, the police found him in the sewer, with a broken neck and the skin on his face peeled off.

    Even Google her name - you'll find this to be true.

    If you don't repost this saying "They hurt her," then Carmen will get you, either from a sewer, the toilet, the shower, or when you go to sleep, you'll wake up in the sewer, in the dark, then Carmen will come and kill you.
    >> Anonymous 08/04/08(Mon)03:57 No.1970308
    >>1970295

    cd /
    exit

    and it should start installing. the root directory was where you needed to be, lol
    >> Anonymous 08/04/08(Mon)03:59 No.1970315
    >>1970308

    lol thanks got it working
    >> Anonymous 08/04/08(Mon)04:00 No.1970326
    ok in acme click in any window and get the cursor to a fresh line. type ls /sys/doc and then (here's the tricky bit) you need to find the correct button on your mouse for this function. for me, this is done by HOLDING IN THE SCROLL WHEEL but it might be different for you. i select the text by holding in the scroll wheel and releasing once it is selected, and the command is automatically exected and a new window spawned.

    then, in the /sys/doc window you have created, you can automatically launch the pdf/ps file viewer just by using the correct mouse button to click on the name of the file! for me, its the RIGHT mouse button. Just click on a pdf or ps file, and it opens in a nice little pdf/ps viewer!
    >> Anonymous 08/04/08(Mon)04:03 No.1970337
    OK EVERYONE USING PLAN 9!!!!!!

    Once everyone gets a little bit of understanding of the system, we should be able to CREATE A TOTALLY MODULAR PLAN 9 CLUSTER over the internet easily, right? I mean, thats what this OS is designed for! The whole point is to make it easy for us to run processes on different cpus, different monitors, store data on different hard drives, all using exactly the same kinds of shell commands etc we are used to.
    >> Anonymous 08/04/08(Mon)04:05 No.1970340
    >>1970307
    i raped her
    >> Anonymous 08/04/08(Mon)04:05 No.1970342
    how long did copydist take for you guys?
    >> Anonymous 08/04/08(Mon)04:06 No.1970345
    I think once we have plan 9 running, all we need to do is:

    1) Make sure networking is setup correctly, and get the correct ports forwarded to the plan 9 virtual machines
    2) make a few simple changes to create our own users so we arent all the 'glenda' default
    3) open the forwarded ports on our firewalls and start the plan9 daemons, and then we can:

    attach new cpus and hard drives over the internet just by doing "bind NAMEOFCPU" and we are transparently clustered.
    >> Anonymous 08/04/08(Mon)04:07 No.1970348
    >>1970342

    if your virtual machine supports dma then copydist goes fast. if it doesnt, its sloooow.
    >> Anonymous 08/04/08(Mon)04:09 No.1970349
    Somebody wanna give me the 404 defeater so I can use this thread as reference?
    >> Anonymous 08/04/08(Mon)04:10 No.1970353
    ctrl-c doesn't work. How do you interrupt a command?
    >> Anonymous 08/04/08(Mon)04:16 No.1970367
    >>1970353

    There are a few ways. You can try ctrl-d , or depending on the kind of thing it is there might be a mouse button to bring up an option to stop it, or in another terminal you can do ps -a and find the name of what you want to stop, then do kill NAME |rc

    why you have to pipe the kill command to rc while you are inside rc is kind of interesting to me
    >> Anonymous 08/04/08(Mon)04:23 No.1970381
    Are there any audio players yet?
    >> Anonymous 08/04/08(Mon)04:26 No.1970383
    >>1970349

    there was a huge thread yesterday with even more info, although the earlier stuff is rough compared to the later stuff.

    PLAN 9 4chan materials archive is now at:

    www.sphericalharmony.com/plan9

    this has a ton of screenshots and the thread from yesterday. to view yesterdays thread this is the URL:

    http://www.sphericalharmony.com/plan9/plan9stuff/lastoneiguess.html

    note that all the pictures in this thread are on the server in the directory, but are NOT linked correctly from that copy of thread, it sends you to an error message on 4chan. find them in the directory directly.
    >> Anonymous 08/04/08(Mon)04:37 No.1970405
    Shit, looks like it's time to dig out the Plan 9 disc I burned a few weeks ago. I meant to get to it, but never did for some reason.
    >> Anonymous 08/04/08(Mon)04:39 No.1970409
    So all the plan 9-ers need to post to 4chan from a web browser inside plan 9 to achieve TROLLPROOF status, once you've done that nobody can really troll you effectively for anything.
    >> Anonymous 08/04/08(Mon)04:44 No.1970416
         File :1217839461.jpg-(148 KB, 1028x775, p9.jpg)
    148 KB
    fuck yeah p9
    >> Root !tnewkRarkA 08/04/08(Mon)04:44 No.1970417
    I just got Plan9 up and running, I see this thread being of some use, how about archiving it?

    I've put in an archive request.
    >> Anonymous 08/04/08(Mon)04:47 No.1970419
    >>1970409
    I would if I could figure out how to take a screenshot...
    I'm running on actual hardware. No VM magic.
    >> Anonymous 08/04/08(Mon)04:49 No.1970420
         File :1217839758.jpg-(212 KB, 1028x769, awesum.jpg)
    212 KB
    this is so awesome
    >> Anonymous 08/04/08(Mon)04:54 No.1970431
    copydist is taking forever
    >> Anonymous 08/04/08(Mon)04:55 No.1970435
    I've been installing for the past 3 hours cause it takes so long, I wander off and dont come back
    >> Anonymous 08/04/08(Mon)04:55 No.1970436
    Why do you guys use Plan 9?
    I heard it's pretty unstable and crappy.
    >> Anonymous 08/04/08(Mon)04:58 No.1970441
    >>1970435

    I cant tell if I'm making any progress either since i somehow hid the progressbar and cant bring it back up. Looking at my virtual hd it's getting bigger (at about 323mb right now) though.
    >> Anonymous 08/04/08(Mon)05:06 No.1970452
    >>1970441
    I havent even gotten to that stage.
    Thats how slow I'm going.
    Though to be fair I did only give it 16mb of ram to work with.
    >> Anonymous 08/04/08(Mon)05:08 No.1970456
         File :1217840887.png-(561 KB, 1024x768, plan9dthrad.png)
    561 KB
    I suppose I probably shouldn't have done this, but I did it anyway. Please forgive me.
    >> Anonymous 08/04/08(Mon)05:10 No.1970461
    >>1970452

    16mb of RAM? are you running on a souped-up TRS-80 or something and thats all the RAM you can afford to give your virtual machine?

    Plan9 wasn't written as an embedded OS, even though the inferno people have gone in that direction with it. Give it some ram!
    >> Anonymous 08/04/08(Mon)05:12 No.1970470
    >>1970436

    It's not unstable, I've never had it crash on me, and I've got an instance of it thats been running for over a day continuously now, doing all kinds of stuff.

    Crappy is a different story, I fully admit that by the "i just wanna use my photoshop and play games blah blah" standard plan9 is absolutely HOPELESS -- but if you like unix stuff, its something that you will probably find very interesting to play around with.
    >> Anonymous 08/04/08(Mon)05:14 No.1970473
    >>1970461
    I just wanted to see the min it could run on
    >> Anonymous 08/04/08(Mon)05:20 No.1970490
    At least you guys aren't Amiga elitists, I'll give you that.
    >> Anonymous 08/04/08(Mon)05:25 No.1970509
         File :1217841920.png-(66 KB, 1280x847, abacorocks.png)
    66 KB
    Abaco is my new favorite webbrowser.

    SUCK IT, OS-ANYONE-HAS-EVER-HEARD-OF-FAGS!
    >> Anonymous 08/04/08(Mon)05:26 No.1970517
    OK copydist finally finished!
    It took about an 1hr 45mins for those wondering.
    >> Anonymous 08/04/08(Mon)05:28 No.1970521
    >>1970456
    lol'd hard
    >> Anonymous 08/04/08(Mon)05:36 No.1970536
    >>1970521

    Original desktop art available at:

    www.sphericalharmony.com/plan9/plangdesktop.jpg
    >> Anonymous 08/04/08(Mon)05:42 No.1970547
    Remember, installers: the virtual machine file isn't that big, make a backup of your plan9 installation because god only knows how to fix a borked system. also, a good idea is to practice doing stuff running the machine in "snapshot" mode where the VM writes changes to the hard drive to temporary files rather than the original image file. in qemu, just launch with -snapshot option.
    >> Anonymous 08/04/08(Mon)05:45 No.1970556
         File :1217843143.png-(10 KB, 640x400, Untitled.png)
    10 KB
    Need help, what do I put in for these 2 prompts at boot?
    root is from (tcp, local)[local!#S/sdC0/fossil]:
    user[none]:

    I'm getting errors and can't figure it out.
    >> Anonymous 08/04/08(Mon)05:45 No.1970557
    Local
    is in the plumbing rules as this :
    type is text
    data matches 'Local (.*)'
    plumb to none
    plumb start rc -c $1 So
    one can plumb a command and any adjustments to the namespace will be reflected across
    the same processes as covered by the instance of the plumber. Then
    you can plumb: Local bind -c /n/unix/some/awfully/long/path/name /n/anything
    This
    is particularly useful if one wants to page something one has found in Acme. A
    little shell script, "local" completes the picture: #!/bin/rc
    plumb 'Local ' ^ $"*
    And
    /n/anything is immediately visible everywhere (including in cpu's shells under /mnt/term)
    and i can plumb files in it without any further hassle. This
    is great when constantly dealing with namespaces that come and go (and particularly since
    i can import namespaces directly from Inferno, which means it's easy to gateway across to
    Windows machines).
    >> Anonymous 08/04/08(Mon)05:48 No.1970561
    >>1970556

    default for the 1st and glenda for the 2nd should be correct, what errors are you getting?
    >> Anonymous 08/04/08(Mon)05:51 No.1970571
    >>1970556

    running in qemu? you may need to adjust your 'acceleration' options, when i was using qemu-launcher i had to select the middle of the 3 options for acceleration.
    >> Anonymous 08/04/08(Mon)05:54 No.1970582
         File :1217843659.png-(12 KB, 640x400, Untitled.png)
    12 KB
    >>1970561

    Some i/o errors.
    >> Anonymous 08/04/08(Mon)06:03 No.1970598
    >>1970582

    shit, that looks a bit nasty, like something on the virtual hd wasnt written correctly. were you
    >>1970420
    because those screenshots look like they are getting kernels errors in the background of the install.
    >> Anonymous 08/04/08(Mon)06:04 No.1970602
    >>1970582

    Does the CD image boot correctly if you select the 'boot from this cd' option? you get a live 'desktop' and you can test your system from there i think.
    >> Anonymous 08/04/08(Mon)06:05 No.1970605
    >>1970598

    No that wasn't me.

    Well it's getting late and I have work in the morning so I'm just gonna call it a night. I'll look for another plan9 thread tomorrow and try to fix it then. Thanks for the help guys.
    >> Anonymous 08/04/08(Mon)06:16 No.1970616
    plan /9/ will save us all. why?

    plan /9/ is run in emulation on the hardware platform of your choice so main OS of choice doesn't matter.

    plan /9/ uses vesa graphics inside a VM, so ati vs. nvidia doesn't matter.

    plan /9/ has abaco vs. vga links for its browser wars, which is new and refreshing compared to IE vs FF vs Opera.

    In short, it is the cancer curing /g/
    >> Anonymous 08/04/08(Mon)06:18 No.1970618
         File :1217845114.gif-(126 KB, 640x364, 1217292535925.gif)
    126 KB
    guess whta
    >> Anonymous 08/04/08(Mon)06:20 No.1970620
    >>1970509
    lol enjoy you're bottom left (I USE UNIX JUST TO SPITE BILL) window butthurt bawwwing faggot
    >> Anonymous 08/04/08(Mon)06:39 No.1970661
    So, in all seriousness, what kind of old crap computer should I look for to find something that can run plan 9 on the real metal? I know they have a hardware list, but it would be nice if someone know that 'oh yeah old compaqs run it' or whatever the hell it is.
    >> Tv capturerer 08/04/08(Mon)06:39 No.1970662
    YOU CANNOT ANNOY MR GATES HE IS SUPREME!!!1
    >> draker !KtMudshitI 08/04/08(Mon)06:50 No.1970696
    Congrats, your request has just triggered the archival process for thread 1969086
    >> Anonymous 08/04/08(Mon)06:54 No.1970707
    >>1970456

    what is the sauce on the original background?
    (name of the artist/nething)
    >> Anonymous 08/04/08(Mon)06:57 No.1970712
    >>1970661
    Thinkpad T30/T40-series works just fine.
    >> Anonymous 08/04/08(Mon)07:13 No.1970744
    >>1970712

    Thanks, I'll hunt for those.
    >> Anonymous 08/04/08(Mon)07:45 No.1970827
    This morning, wake up with Glenda.

    Wake up ith Plan 9.

    An os that doesn't bore you with the same tired apps you've seen a thousand times.

    An os that doesn't bow to market pressure for easy configuration.

    An os that you will never, every truly understand.

    Welcome to the plan.

    Plan /9/. Because anything else isn't abstract enough.
    >> Anonymous 08/04/08(Mon)08:01 No.1970873
    >>1969086
    >>1969160
    >>1969323
    >>1969360
    >>1969388
    >>1969398
    >>1969410
    >>1969423
    >>1969773
    >>1969778
    >>1969800
    >>1969819
    >>1969925
    >>1969951
    >>1969959
    >>1970011
    >>1970072
    >>1970073
    >>1970141
    >>1970144
    >>1970180
    >>1970183
    >>1970194
    >>1970201
    >>1970204
    >>1970208
    >>1970211
    >>1970214
    >>1970218
    >>1970222
    >>1970224
    >>1970230
    >>1970247
    >>1970259
    >>1970267
    >>1970291
    >>1970297
    >>1970306
    >>1970326
    >>1970337
    >>1970345
    >>1970367
    >>1970383
    >>1970456
    >>1970461
    >>1970470
    >>1970509
    >>1970547
    >>1970556
    >>1970557
    >>1970827
    4chan needs a /plan9/ board.
    >> Anonymous 08/04/08(Mon)08:18 No.1970916
    >>1970873

    Indeed it does. Once we have a few people running the OS, we should be able to do some REALLY COOL SHIT at least if you think doing grid computing/clustering via random heterogenous boxes over the net is cool.


    Delete Post [File Only]
    Password
    Style [Yotsuba | Yotsuba B | Futaba | Burichan]
    Watched Threads
    PosterThread Title
    No Threads Watched