Posting mode: Reply
Password(Password used for file deletion)
  • Supported file types are: GIF, JPG, PNG
  • Maximum file size allowed is 3072 KB.
  • Images greater than 250x250 pixels will be thumbnailed.
  • Read the rules and FAQ before posting.
  • このサイトについて - 翻訳
  • Blotter updated: 07/19/08

  • For future reference, check status.4chan.org for updates when the main site is unreachable.
    Flush your DNS cache and clear your hosts file.
    A news post will go up some time in the next 48-72 hours.

    File :1217861547.png-(106 KB, 1024x768, plan9_ss1.png)
    106 KB Anonymous 08/04/08(Mon)10:52 No.1971270  
    It's time for Plan 9 /g/. Everything else failed.


    inb4 gentoo (or whatever) linux
    >> Rage is the New Sage !!7RhNVYjQ2Y/ 08/04/08(Mon)10:56 No.1971285
    How difficult is it to install and use?

    I know my way around a command line but i'm not going to the trouble of compiling the entire thing and setting all the configs myself.
    >> Anonymous 08/04/08(Mon)10:57 No.1971290
    Welcome to 1991.
    >> Anonymous 08/04/08(Mon)10:58 No.1971295

    Captain Archer is a jerk.
    >> Anonymous 08/04/08(Mon)10:59 No.1971298
    I've got to go to work now, but I'll be installing it when I get home. I suppose that Dell Dimension 4100 had to be good for something.

    Here's a link to last night's Plan 9 thread:
    >> Anonymous 08/04/08(Mon)11:00 No.1971302
    It was nice to have a break in the moral faggotry associated with star trek
    >> Anonymous 08/04/08(Mon)11:00 No.1971304

    >Welcome to 1991.

    When computers were still good.
    >> Anonymous 08/04/08(Mon)11:02 No.1971309

    It pretty much depends on what you mean by "use". P9 right now can't be called a proper OS, more like a hobby thing. If you look for usability as in GAEMS or SHOOPDAWHOOP then it's not for you. If on the other hand you're interested in awesome little features, such as distributed computing and mesh networking, extended namespace, then it's for you and by any means you should give it a try. It's not that difficult to install, as long as you have some help here on on the P9 board, but using it might feel weird at first.
    >> Bill Gates http://maru-ch.ath.cx !!jvCuWJ8NrnK 08/04/08(Mon)11:04 No.1971315
         File :1217862250.jpg-(11 KB, 260x221, 1215457448550.jpg)
    11 KB
    >> Anonymous 08/04/08(Mon)11:05 No.1971321
         File :1217862336.jpg-(156 KB, 1280x1024, posting_from_plan9..jpg)
    156 KB
    lol POSTING FROM PLAN9 - wait - FUCK!
    >> Anonymous 08/04/08(Mon)11:17 No.1971358
    >> Anonymous 08/04/08(Mon)11:21 No.1971371
    I'm in the process of setting up PLAN 9. Can't wait for phase 2.
    >> Anonymous 08/04/08(Mon)11:22 No.1971372
    >> Anonymous 08/04/08(Mon)11:23 No.1971382
         File :1217863423.png-(1.19 MB, 1440x900, installanplan9.png)
    1.19 MB
    Installing Plan 9 in qemu VM on Ubuntu 8.04 now.
    >> Anonymous 08/04/08(Mon)11:24 No.1971390
         File :1217863483.jpg-(694 KB, 1680x1050, New Bitmap Image.jpg)
    694 KB
    Also posting from Plan 9
    >> Anonymous 08/04/08(Mon)11:27 No.1971397
    Hobby OS within a Hobby OS. NOW WHY DIDN'T I THINK OF THAT?!?!
    >> Anonymous 08/04/08(Mon)11:27 No.1971400
    Ok, so Phase 1 of Plan 9 - Deployment, is underway. Keep it up, /g/entlemen!
    >> Anonymous 08/04/08(Mon)11:29 No.1971405
    ok, who else thinks of installing Plan9 on his friends mac as the sole operating system? would love to see the fuckers face...
    >> Anonymous 08/04/08(Mon)11:29 No.1971408
    /r/ing that wallpaper
    >> Anonymous 08/04/08(Mon)11:34 No.1971422
    >ok, who else thinks of installing Plan9 on his friends mac as the sole operating system? would love to see the fuckers face...

    That wood be so lol becuz maks are dum
    >> Anonymous 08/04/08(Mon)11:35 No.1971423
         File :1217864119.jpg-(457 KB, 1600x1200, ymht015.jpg)
    457 KB

    >> Anonymous 08/04/08(Mon)11:37 No.1971427
         File :1217864244.jpg-(978 KB, 1440x900, 1204934396470.jpg)
    978 KB
    this anon thanks you.
    >> Anonymous 08/04/08(Mon)11:37 No.1971429
    No OS wars please -- PLAN /9/ can be run in a virtual machine inside Windows, Linux, or OS X. Escape from your boring useful OS into an exciting semi-functional one! Join the journey into an alternate reality of computing, where its assumed that keeping track of namespace inheritance trees is 'intuitive'!
    >> Anonymous 08/04/08(Mon)11:39 No.1971436
    No thanks. I'd rather be gaymen.
    >> Anonymous 08/04/08(Mon)11:40 No.1971441
    Why would you guys use a highly experimental OS with a bunch of neat ideas but horrid software and hardware support?

    Oh well, it's better than reading OS TROLLAN WARS THREAD again for the umpteenth time.
    >> Anonymous 08/04/08(Mon)11:42 No.1971443
    are you talking about Plan 9 or Linux?
    >> Anonymous 08/04/08(Mon)11:44 No.1971451

    1) because once we get a few of us running it, we can setup a plan/9/grid distributed setup, where we can all attach the same virtual filesystems to our machines, pass processes around between different cpus, and generally do fucked-up crazy shit.

    2) because what are we supposed to do, shoop tidus for the 10 billionth time, or tell random person looking for advice to buy q6600 and hd4870?

    'Install Plan 9' was always just a random troll comment, but now we can do something real with it. This is open source free software, we can create a customized plan /9/ setup that people can just download and automatically plug into our /g/rid.
    >> Anonymous 08/04/08(Mon)11:47 No.1971460

    Plan 9. Linux actually has software and hardware support. Half-assed support, but it's there.


    I see. Interesting.

    Anyway, does Plan 9 actually have a chance to be commercialized for some sort of cloud computing application, a la Midori?
    >> Anonymous 08/04/08(Mon)11:50 No.1971473
    OK there are a bunch of guys on here asking "Why would I do this?"

    Number 1: We are telling you to get plan9 set up in a VIRTUAL MACHINE. Not directly on your hardware.. we want people to start learning how it works

    Number 2: After it's running on a virtual machine we will set up a phat cluster so we can share spare MBs, files, port, CPU cycles... etc. It'll be like a service.... like "I want porn and mp3's.. .time to fire up my plan9.. or oh jeez I need to recompile my gentoo.. well I'll just cross-compile it in plan9... since someone already has all the sources posted up anyhow

    Number 3: We can make plan9 into something people can use.

    So anyhow using X11's remote capabilities combined with virtual machines.. you';ll be able to do plan9 stuff pretty much transparently on your computer and keep your primary OS and shit.. you'll just have a super fast computer available when you need it.. providing you're sharing out some of your own resources as well.
    >> Anonymous 08/04/08(Mon)11:52 No.1971480
    >Plan 9. Linux actually has software and hardware support. Half-assed support, but it's there.

    This is not relevant.. the most practical way to do this is to run it in a virtual machine anyhow.. if you're running this directly on your hardware.... you're doing it wrong.

    >Anyway, does Plan 9 actually have a chance to be commercialized for some sort of cloud computing application, a la Midori?

    I thinkl we're on the brink of creating a large anon clout.. which will be 1000x more awesome.
    >> Anonymous 08/04/08(Mon)11:54 No.1971491

    Wow, I hope we can get it working that well! I'll be freaking excited if we can just get a few people running 9fs service because that alone lets you do a ton of shit. I'm checking out some web resources for this stuff, theres actually quite a bit going on, google 9grid and you find a fair amount of projects and thats probably not all of them, although a lot of it looks just as flaky as what we are talking about.
    >> Anonymous 08/04/08(Mon)11:55 No.1971493

    Wouldn't all this file sharing be limited by the persons connection speed? You'd still have to connect to everyone use over the net.
    >> Anonymous 08/04/08(Mon)11:56 No.1971494
    so like, we can set up some sort of plan9 distributed computing network, where we can focus our processing power on achieving something we couldnt do on our own?

    like hack the gibson etc?
    >> Anonymous 08/04/08(Mon)11:56 No.1971495
    i'm going to google some porn instead.
    >> Anonymous 08/04/08(Mon)11:56 No.1971497

    Midori so far is nothing but bullshit, nothing concrete and it's years away from completion, it's even farther behind than Plan/9/ is at the moment.

    Also, Plan/9/ is free, no need for it to be sold or bought, like Midori most likely will.
    >> Anonymous 08/04/08(Mon)11:58 No.1971501
    guys, what VM is best (and free) for winxp?
    >> Anonymous 08/04/08(Mon)11:58 No.1971503

    Yeah, pretty much. For example, imagine AWESOME filesharing without the risk of being V&.
    >> Anonymous 08/04/08(Mon)12:00 No.1971510

    not sure, the easiest way to get started maybe with the vmware preinstaslled image or something? Im in ubuntu, ive got a perfect setup using qemu, but ive heard windows qemu is more of a hassle.
    >> Anonymous 08/04/08(Mon)12:01 No.1971516
    We could actually use this for shit, or just be a mad folding@home power.
    >> Anonymous 08/04/08(Mon)12:08 No.1971532
         File :1217866102.png-(18 KB, 642x506, NEWUPDATES.png)
    18 KB
    OMFG GUIZE!!!!!!!!!!!!!





    >> Anonymous 08/04/08(Mon)12:12 No.1971541
    seriously, do you know what I think just happened??

    because of all of us seeing this thread and starting to pound their servers whoever is maintaining said

    "oh shit, we better push those updates out, ppl are downloading!"

    this could actually be really interesting...

    plan 9 was designed for a truly networked environment, and maybe the environment it was designed for -- ubiquitous net and tons of random hardware connected to it -- is finally here...

    and so it begins.
    >> Anonymous 08/04/08(Mon)12:12 No.1971543
    winxp user here

    downloading plan9 and vmware, never done this stuff before but i understand the general concept

    limited experience of other OSes, but im looking forward to trying out plan9 and seeing what it can do

    brace for impact
    >> Anonymous 08/04/08(Mon)12:14 No.1971550
         File :1217866475.png-(64 KB, 1030x793, lolplan9.png)
    64 KB
    I don't "get" plan9
    >> Anonymous 08/04/08(Mon)12:17 No.1971557

    The first thing to do is to learn a bit about how to control rio (the window manager) and acme (the big window you have up now) and rc (the shell+its custom rio interfaces)

    here's a tutorial i just found, it seems recent and pretty good:


    need help getting internet services and a web browser and shit going?
    >> Anonymous 08/04/08(Mon)12:18 No.1971562

    in acme, on my mouse, clicking in on the mouse wheel is the 'do this' command, clicking on the right mouse button is 'show me this' and left mouse button moves the cursor and select text for use by the verbs on the top line of the miniwindows.
    >> Anonymous 08/04/08(Mon)12:21 No.1971576
    ugh, thanks.

    getting the net going would have to involve me setting up some kind of openssl virtual network device whatchamacallit first, I'll leave that for some other day
    >> Anonymous 08/04/08(Mon)12:31 No.1971609
    are you sure networking would require anything as complex as you are saying? with a standard residential setup internet is basically 'instant on' with a few commands copypasted from the man ipconfig examples.
    >> Anonymous 08/04/08(Mon)12:35 No.1971630
    i lol'd
    >> Anonymous 08/04/08(Mon)12:40 No.1971643
    I was looking at this page:

    way too lazy to do that tonight
    >> Anonymous 08/04/08(Mon)12:42 No.1971650
         File :1217868179.jpg-(122 KB, 800x600, 90_Star_Trek_Enterprise_schema(...).jpg)
    122 KB
    Plan/9/ is one of the very few things worth F5'ing.

    It has officially ascended to the status of awesome.
    >> Anonymous 08/04/08(Mon)12:48 No.1971666
    Install from earlier in the thread finished, got myself decently setup now. I enabled networking just by using acme (the editor/filemanager thats launched with multiple panes on startup) to uncomment two lines in /rc/bin/termrc to enable dhcp on boot.

    after rebooting, the network was up and so i did in rc shell:

    9fs sources

    which updated me, then i did

    /n/sources/contrib/fgb/root/rc/bin/contrib/install fgb/contrib
    contib/install fgb/abaco

    which installed the browser, which you have to start each time in terminal with:


    after i tested that abaco was working, i decided to save the state of my system by stopping and backing up. to deactivate your system, do:


    and after it says system halted, just kill the window, shut it down in the virtual machine, whatever. After I did that I backed up my vm so Id ahve a working base system with internet if i screw anything up or plan9 crashes and corrupts its filesystem or something
    >> Anonymous 08/04/08(Mon)12:51 No.1971678
         File :1217868707.png-(471 KB, 1440x900, newinstall.png)
    471 KB

    heres a pic of the system running post setup, and the terminal window is showing the /rc/bin/termrc file with the two lines for dhcp autoconfig that you have to uncomment. in this pic they are uncommented because the box is all setup.
    >> Anonymous 08/04/08(Mon)12:57 No.1971690
    >i'm going to google some porn instead.

    Only noobs use google to find porn.
    >> Anonymous 08/04/08(Mon)13:01 No.1971709
    Here is the right attitude to take to approaching Plan 9:

    Pretend its a totally crazy puzzle-videogame where you are hacking into an alien computer system, trying to make it work. If you approach things in that spirit, you will have a ton of fun, and its actually NOT all that hard to get things going.

    I'm actually working on a secret plan to implement an almost 1-click process for a scripted /g/ autoconfig right after first boot.
    >> Anonymous 08/04/08(Mon)13:13 No.1971750
    >i'm going to google some porn instead.

    Enjoy your paysites, malware, boring garden variety porn, and 10 second video clips.
    >> Anonymous 08/04/08(Mon)13:29 No.1971788
    I'm working on getting Plan9 working in QEMU (on linux)

    Anyone have some guides on setting up the networking? (Preferably ones specific to QEMU, since I'll need to get some kind of internet sharing going on)
    >> Anonymous 08/04/08(Mon)13:38 No.1971812

    YES! It's very simple. Here's the easiest way to do it "on the fly":

    in rio terminal do

    man ipconfig

    then use the arrow keys to move the screen down towards near the end where it gives the following sample commands for dhcp:

    bind -b '#l0' /net
    bind -a '#I0' /net
    ndb/dns -r

    if you highligh a command with the mouse, then hold in on the scroll wheel (assuming your buttons are the same) and choose 'send' it sends the highlighted command as a command to the terminal you are in. just highlight and 'send' each command from the manpage in turn, and your net should then be working! after that, do

    9fs sources

    to update
    >> Anonymous 08/04/08(Mon)13:41 No.1971823
    Any tips on getting Plan 9 to run under OSX on a Macbook? Sun's Virtualbox doesn't do it properly.. IIRC it's painfully slow to start and the whole thing crashes when it tries to launch the window system. Would it be any better under Parallels?

    inb4 macs are for faggots crap
    >> Anonymous 08/04/08(Mon)13:42 No.1971825

    plan 9 is awesome in qemu in linux, thats how I run it and i have set it up 3 times on 3 different machines now. the huge initial thread on this from a couple nights ago is at:


    but dont start doing everything I did, i screwed a lot of stuff up. there are tons of screenshots in the


    directory, they arent linked from the archived page correctly but they are there
    >> Anonymous 08/04/08(Mon)13:43 No.1971831

    apparently it works well in parallels. go to the plan 9 wiki:


    and follow the links there
    >> Anonymous 08/04/08(Mon)13:53 No.1971860

    Also an archive of the 2nd huge plan 9 thread:

    >> Anonymous 08/04/08(Mon)14:17 No.1971973
    hey what window theme is that?
    >> Anonymous 08/04/08(Mon)14:17 No.1971975
    In addition to the 'plan 9 native' abaco browser, which has some cool plan 9 type features, you probably also want the links browser. after getting networking up:

    9fs sources
    cp /n/sources/contrib/andrey/links.tgz /usr/glenda/tmp
    cd /usr/glenda/tmp
    tar xzf links.tgz
    cd links-varfont
    mk install
    >> Anonymous 08/04/08(Mon)14:19 No.1971984
    Theme in the screenshot is called Candybar its from standard gnome themes website.
    >> Anonymous 08/04/08(Mon)15:01 No.1972176
    Random plan9 tip:
    if you want a somewhat more traditional terminal, just type 'vt' in rc terminal, and it changes to vt-100 emulation mode. sort of, more or less. buttons 2 and 3 do cool stuff still, but different than in rc.
    >> Anonymous 08/04/08(Mon)16:44 No.1972832
    I have a question.
    Is it possible to make a simple web server that, instead of outputting its over HTTP, it does everything over the Plan 9 filesystem?
    If so, would it be possible to set up a Plan9chan so that you could just point your browser to "/n/plan9chan/index" and view our own special image board?
    >> Anonymous 08/04/08(Mon)16:46 No.1972843
    plan9 is new tidus
    >> Anonymous 08/04/08(Mon)16:52 No.1972873

    I think those already exist -- because part of plan 9 is 'webfs' which interfaces http with the file system, and there are plan 9 webservers, more than one.

    Consequently, its the easiest thing in the world for plan 9 to map the internet to whatever point in the namespace you want, and then just provide a 'plumber' agent that knows you want to deal with that directory as webpages.

    At least, thats the gist of my understanding as a plan 9 noob. Right now I know how to use plan 9 basically as a crappy linux distro -- i havent figured out the awesome network connectivity yet. Trying to walk before we fly...
    >> Anonymous 08/04/08(Mon)16:59 No.1972909
    Yes, that is easy. Really easy. The 9P protocol acts as a wrapper for essentially all other protocols, including HTTP.
    >> Anonymous 08/04/08(Mon)17:06 No.1972982
    finally, a real thread. If you guys are serious about this, I'll have to install plan 9. I haven't previously only because I haven't had anyone else to do it with, and having plan 9 alone is a total waste of effort.
    >> Anonymous 08/04/08(Mon)17:13 No.1973031

    We are absolutely intending to put plan /9/ into effect and actually create a /g/ 9grid and basically advance to the NEXT LEVEL of computing. In fact, maybe our plan 9 setup can become the FINAL BOSS OF THE INTERNET or something.

    All the documentation to do this is out there, and I don't think its even hard -- just make sure your virtual machine can network properly, setup port forwarding on the right router ports, configure whatever the fuck the user/password model is (I know it uses something called 'factotum' to handle authentication) and then start our daemons and we should be able to do all the cool stuff that p9 was designed for.
    >> Anonymous 08/04/08(Mon)17:15 No.1973044
    The 9grid sounds pretty sweet.
    >> Anonymous 08/04/08(Mon)17:18 No.1973065
    We need to make a distributed chan.
    >> Anonymous 08/04/08(Mon)17:22 No.1973095
    there was a program that setup a distributed webpage network but i cant remember what it was called and it was slow as fuck
    >> Anonymous 08/04/08(Mon)17:29 No.1973153

    'slow as fuck' is probably going to be an EXCELLENT DESCRIPTION of grid computing via residential ISP dsl/cable ethernet services. Remember, regardless of your download speed, you are probably capped around 60k/sec for upload...
    >> Anonymous 08/04/08(Mon)17:32 No.1973170
    All respects to the people at Bell Labs, but DragonFly BSD is going to beat the living fuck out of Plan 9 in a couple of years.
    >> Anonymous 08/04/08(Mon)17:32 No.1973171
    so we're going to use plan 9 and not inferno for the grid project thing?
    >> Anonymous 08/04/08(Mon)17:35 No.1973182

    Well, can't inferno run on top of plan 9? this whole project is just a rolling snowball of people realizing 'holy shit, it only takes an hour to get started with plan9, its the weidest shit ever, and it will enable us to HIVEMIND HIVECOMPUTE'

    right now nobody has even pasted a sample of the commands to actually set stuff up. im sure you just have to flip a config switch or two to enable external access, create a namespace, bind/mount a daemon onto the namespace, and youre good to go, but ive been too busy randomly fucking with really basic shit like trying to figure out how the MOUSE BUTTONS and the cursor work...

    so i havent quite mastered the 5 terabytes of documentation on the system
    >> Anonymous 08/04/08(Mon)17:44 No.1973248
    snarfed, then Pasted, from man 9fs:
    Srv dials the given machine and initializes the connection
    to serve the 9P protocol. By default, it connects to the
    `9fs' (9P) service, which for TCP is port 564. It then cre-
    ates in /srv a file named srvname. Users can then mount (see
    bind(1)) the service, typically on a name in /n, to access
    the files provided by the remote machine. If srvname is
    omitted, the first argument to srv is used. Option m
    directs srv to mount the service on /n/system or onto mtpt
    if it is given. Option q suppresses complaints if the /srv
    file already exists. The a, b, c, C, and n options are used
    to control the mount flags as in mount (see bind(1)). The e
    option causes srv to treat system as a shell command to be
    executed rather than an address to be dialed. The s option
    causes srv to sleep for the specified number of seconds
    after establishing the connection before posting and mount-
    ing it. This is sometimes needed by srvssh.
    >> Anonymous 08/04/08(Mon)17:45 No.1973250
    Holy shit. I'm really loving Acme.
    >> Anonymous 08/04/08(Mon)17:46 No.1973254
    Somebody wanna post a complete install guide?
    >> Anonymous 08/04/08(Mon)17:49 No.1973263
    Think about the download speeds obtainable via bittorrent. The combined upload speed would be able to easily cover what was needed. Unlike other distributed webpage networks, which use the distribution aspect for greater storage space and survivability, a chan network would be based around high levels of redundancy. This isn't going to be like freenet which overemphasizes privacy.

    The only problem with a solution like this is webpages are inherently dynamic, which doesn't translate well into distributed networks. This could however be solved by distrubting conversation in a hierarchal fashion, with conversations divided up among multi-tiered categories, with redundancy throughout. When a post is made to one server, it propagates that post to other servers. Over time, posts could be pruned on a per-server basis.


    This sounds familiar.

    >> Anonymous 08/04/08(Mon)17:50 No.1973267
    thread hidden
    >> Anonymous 08/04/08(Mon)17:51 No.1973275

    I'd start out looking at


    and figuring out what VM is best for your OS. The install itself is fairly easy. Here are a couple archived 4chan threads with a ton of info, some good, some misguided, but with a lot of mini-how tos:


    there is also the very beginning of a /9/ discussion area and hopefully knowledge base at

    >> Anonymous 08/04/08(Mon)17:51 No.1973276
         File :1217886705.jpg-(15 KB, 219x93, 1211490604211.jpg)
    15 KB
    >> Anonymous 08/04/08(Mon)17:54 No.1973289

    acme is amazing! i still havent learned everything that it can do because its partially based on mouse chords! multi button mouse combos that is. What i know so far:

    right-click will 'plumb' an object to a correct handler, such as a .pdf file to the pdf viewer, or create a new window with the contents of a directory. type / and right click on it and POW a new window with a root file list appears.

    middle click is 'do' and can execute commands from the top menus, OR you can use hold-down-middle select-drag-release to issue any command! so type ls /bin |grep f and middle-button select and release, and pow! window pops up with the results of the command.

    its like a combination file-manager/shell/process launcher.
    >> Anonymous 08/04/08(Mon)18:00 No.1973313
         File :1217887212.png-(65 KB, 1024x768, acmepower.png)
    65 KB

    heres a screenshot of some acme stuff, all done with SINGLE BUTTON CLICKS of the left and center (wheel) mouse buttons: just right click to show a directory or file contents, middle click to execute a command -- so by going to the /bin directory and middle-clicking on fortune, i could spam fortunes in the window on the right side!
    >> Anonymous 08/04/08(Mon)18:01 No.1973322
    Whats the minimum you guys think this could run on?
    After I finish installing on a virtual machine with 64mb memory and 8mb video, I'm gunna do 1mb video and 8mb ram
    >> Anonymous 08/04/08(Mon)18:03 No.1973331
    wait a second...
    once we get our setup in place, people won't even have to INSTALL, right? I mean, THIS IS PLAN 9! All they have to do is boot from the live cd, issue the networking commands, and then do 9fs and bind the /g/ namespace on right? set up the right namespace bindings and they can even run all their processes on the grid, just be a diskless client, right?

    >> Anonymous 08/04/08(Mon)18:04 No.1973339

    I think that small a machine CAN be used, but only as a display/input client for a rio session running on a networked cpu.

    thats my guess.
    >> Anonymous 08/04/08(Mon)18:08 No.1973358
    well I mean
    its not like this would take much processing power. And it's using less than a fourth of the 64mb I've allocated to it.
    >> Anonymous 08/04/08(Mon)18:09 No.1973362

    Look at that picture carefully. It shows the acme all purpose editor/file manager/process launcher in the middle, and in the upper left behind it is the abaco web browser. notice anything interesting?

    the abaco web browser is clearly built on the acme infrastructure, just with a lot of built-in plumbing to handle the data that its getting out of webfs
    >> Anonymous 08/04/08(Mon)18:13 No.1973383
    I'm trying to set up a HTTP server. I found ip/httpd/httpd and tried to invoke it alone and with aux/listen1 tcp!*!http httpd.
    The last command makes my box listen on the port 80, but aux/listen1 doesn't seems to relay the requests to httpd.

    >> Anonymous 08/04/08(Mon)18:22 No.1973441

    wow, you are way ahead of me, have you tried finding some docs for the http server you installed? there are several different webserver packages available.

    I've become totally addicted to acme: in this screenshot, look over at the /bin listing -- all i did was put the cursor next to the 'primes' command, put in the arguments (range of numbers) and did the middle button select-and-release and it executed the primes command in a new window with the arguments i specified.

    over on the right i discovered a cool app that lists all the stuff that can be installed with contrib/install tool -- note that this is NOT all the contrib software, only the small number of packages that use that mechanism! most stuff is in tarballs of source code that you install by copying it over to your tmp directory, tar xzf FOO.tgz cd FOO, mk install

    anyway, acme is incredible
    >> Anonymous 08/04/08(Mon)18:22 No.1973447
         File :1217888564.png-(66 KB, 1024x768, moreacme.png)
    66 KB

    oops, forgot my screenshot...
    >> Anonymous 08/04/08(Mon)18:28 No.1973486

    Well, I haven't tried Plan 9, but the screenshots in this thread show directories like 68000/ and 68020/. If Plan 9 runs on those machines, then it's requirements are really low. 68000 can address at most 16MB of memory and is comparable to 80286.
    >> Anonymous 08/04/08(Mon)18:30 No.1973501

    wait, I bet I know what you did! -- at least part of it --

    do you understand how namespace 'inheritance' works in plan 9? if you start two rc shells next to each other from rio, they will share the same namespace setup initially, but the binds you make within each terminal will only apply to the processes launched within that terminal -- see you get a global setup of bindings from the glenda user setup that applies to everything you start within rio -- but if you add on new stuff to those initial bindings, the newly constructed namespaces only apply to stuff started by that terminal.

    this applies to 9fs sources -- you will notice that if you 9fs sources in one terminal, a separate terminal wont 'see' the stuff in /n/sources because the namespace binding doesnt apply because its in a 'parallel' space -- it shares the default glenda namespace bindings that apply to everything launched off of your rio instance, but nothing else unless you construct that binding within that shell's namespace.
    >> Anonymous 08/04/08(Mon)18:32 No.1973509

    Plan 9's minimal system requirements are a system with a monitor, keyboard, mouse, network connection, and enough ram to store the video framebuffer and connect the I/o pipes, basically.
    >> Anonymous 08/04/08(Mon)18:33 No.1973518
    >> Anonymous 08/04/08(Mon)18:36 No.1973539
         File :1217889414.png-(12 KB, 640x400, Untitled.png)
    12 KB
    Halp. I'm getting i/o errors at boot.
    I used the default for the first prompt and glenda for the second prompt.
    I'm stuck and don't know what to do?
    >> Anonymous 08/04/08(Mon)18:38 No.1973554
    Are you running in a VM or on actual hardware?
    If you're running in a VM, what VM are you using?
    >> Anonymous 08/04/08(Mon)18:40 No.1973562
    So, who needs help with something less complex than an http server? Does everyone have their network up, either abaco or links installed, and know generally how to work with the /n/sources/contrib area?

    There are good ports of a lot of important apps, although they may not be 'plan 9-ified' - for instane the links browser is faster, but abaco is cooler because it can do more with plumbing, etc. notable packages ive brought in are openssl+openssh (works best if you use the vt terminal) and vim -- loooooong build time on vim, but all this stuff is available via the contrib/install package manager.
    >> Anonymous 08/04/08(Mon)18:41 No.1973568

    This is the 3rd report ive seen of these errors, I think it clearly results from a certain combination of OS and VM and perhaps configuration. please describe your setup so we can figure out at least what to tell people doesn't work
    >> Anonymous 08/04/08(Mon)18:42 No.1973569

    Virtual PC 2007

    Right now I'm reinstalling on VirtualBox but if you guys could help me get past the boot on VPC that would be great.
    >> Anonymous 08/04/08(Mon)18:43 No.1973575
    what happened to plans 0-8?
    >> Anonymous 08/04/08(Mon)18:46 No.1973595

    VirtualPC 2007
    128MB RAM
    521MB HDD
    Fossil file system
    Didnt create a swap partition
    Didnt prepdist
    Chose local media to obtain distribution
    Chose / directory for copydist
    Copydist took 2hours if anybody is wondering
    Chose plan9 boot
    >> !b62wViQvnA 08/04/08(Mon)18:47 No.1973609
         File :1217890063.png-(69 KB, 760x483, p9vmfail.png)
    69 KB
    I installed it but it's stuck on this part every boot.
    >> Anonymous 08/04/08(Mon)18:49 No.1973626

    post your config like this
    >> !b62wViQvnA 08/04/08(Mon)18:53 No.1973647
    sure thing
    VMware 6.0.4
    192mb RAM
    8 gig HD
    Didn't create a swap partition
    Didn't encounter "prepdist"
    Chose local media to obtain distribution
    Chose / directory for copydist
    copydist took ~15min
    Chose plan9 boot on mbr
    >> Anonymous 08/04/08(Mon)18:53 No.1973652
    Right now I'm trying to install Python.
    I downloaded the package from /n/sources/extra/python.iso.bz2, but I have absolutely no idea how to open ISO images.
    >> Anonymous 08/04/08(Mon)18:55 No.1973667
    OK, I think several popular VMs dont necessarily work with Plan 9

    The plan 9 wiki has howtos for the following vms:


    I believe that virtualbox vista at least is confirmed as working, maybe other windows vboxes work also, i know that linux vbox does NOT work when i tried. qemu works great and was a snap to setup for me.
    >> !b62wViQvnA 08/04/08(Mon)18:55 No.1973670
    oh and 800x600x32 xga monitor (vesa caused a vmware stack fault)
    >> Anonymous 08/04/08(Mon)18:57 No.1973685
    I'm working with VIrtualBox right now I'll give a full report when it's done for those who are running into errors at boot.
    >> Anonymous 08/04/08(Mon)18:57 No.1973686

    Did you follow the vmware how-tos at the wiki?


    I have also heard that there is a pre-installed vmware plan 9 image available for download, it has been mentioned a few times. look at the vmware site's collection of images, i think.
    >> Anonymous 08/04/08(Mon)18:59 No.1973704
    Not about mouting ISO images, but it's explained in the first part.
    >> Anonymous 08/04/08(Mon)19:00 No.1973714

    hmm there is some mention of a vesa related issue on the wiki, it indicates you need to turn off hardware acceleration on the Vmware machine I think. the wiki info seems kinda sketchy and outdated and maybe more linux than windows focused, so if we have some people with direct current experience that would be better.
    >> Anonymous 08/04/08(Mon)19:01 No.1973723
    Virtualbox works flawlessly.
    >> Anonymous 08/04/08(Mon)19:03 No.1973729

    i think you need to use the plan9 cd and choose the 'debug plan9.ini' option and maybe add this to /rc/bin/termrc

    echo hwaccel off > /dev/vgactl

    this is from the vmware page on the wiki and it seems like it might be related if you are freezing during the init process.
    >> Anonymous 08/04/08(Mon)19:07 No.1973747

    Ok so virtualbox is good in windows, not good in linux. I started a list of /g/ confirmed working host OS + VM combinations at the anonib site, so far i have ubuntu+qemu and windows+virtualbox listed, i know there are quite a few more but damned if i can keep it straight in my head, please poast working setups and any install tips!
    >> !b62wViQvnA 08/04/08(Mon)19:07 No.1973748
    Virtualbox took like 5 minutes to load the first install screen for configfs, that's why I gave up on it
    >> Anonymous 08/04/08(Mon)19:09 No.1973756
         File :1217891372.png-(43 KB, 1024x768, bindforbabies.png)
    43 KB
    Ok, on the subject of learning the OS: i know the key to plan 9 is the namespace, and the tool to construct the namespaces is basically just binding/mounting directories together, with various flags and options for all the 'special' directories like directories that are actually links to the internet, etc, etc. Heres a screenshot of some 'bind for babies' just operating on totally generic useless directories. terminal in lower left, man bind page partially visible in upper right.
    >> Anonymous 08/04/08(Mon)19:10 No.1973759
    virtualbox should be the ONLY vm you use in windows.

    Also, woo plan9 is FINALLY copydist'ing.
    At a whopping 0% after 10 minutes.
    >> !b62wViQvnA 08/04/08(Mon)19:14 No.1973793
    Thanks switching CD-ROM to SCSI worked.
    >> Anonymous 08/04/08(Mon)19:14 No.1973796

    VirtualBox (in Windows) seems to be doing something strange with Plan9, it runs REALLY slowly, the interrupts graph in gnot is always maxed too, possibly related?

    I switched from VirtualBox to QEMU + kqemu and it installed a heck of a lot quicker.
    >> Anonymous 08/04/08(Mon)19:18 No.1973816

    Same here. I'm at the mountfs stage and it took about 20mins for it to finish. On VPC it was much faster.
    >> Anonymous 08/04/08(Mon)19:18 No.1973826
         File :1217891935.png-(31 KB, 1024x768, betterthancrysis.png)
    31 KB

    Fool, what are you wasting your time like that for?

    Plan 9 is for GAEMAN. pic related.
    >> Anonymous 08/04/08(Mon)19:20 No.1973839

    My guess is that vbox windows + plan 9 doesnt support DMA transfer to the hard drive. Consequently, I can't even imagine how slow the install is going to go...I think I read about this issue somewhere on random paged of googled information #5754645
    >> Anonymous 08/04/08(Mon)19:23 No.1973856
    plan9 doesnt support dma anyways.
    >> Anonymous 08/04/08(Mon)19:25 No.1973870

    Yea I think I read that in last nights plan9 thread.
    Some guy was saying without DMA it would take forever.

    Little update: plan9 has been "Preparing menu" for finding the distribution for 15 mins now. Seems
    awfully slow.
    >> Anonymous 08/04/08(Mon)19:27 No.1973895

    That sounds disastrous. Did you try booting it as a live CD and seeing how the graphical environment ran? Using qemu, even without the kqemu module, my plan 9 is very snappy, even on a crappy ubuntu box with 384 mb ram and a sempron 3000 cpu.
    >> Anonymous 08/04/08(Mon)19:28 No.1973900

    when I've installed plan 9, more than one it has asked me if I want to use DMA transfer mode for the hard drive in my virtual machine. if you really don't believe me, I could get a screenshot i guess.
    >> Anonymous 08/04/08(Mon)19:30 No.1973917
    I read on one of their faq's that it didnt support dma, even though it asked for it.
    >> Anonymous 08/04/08(Mon)19:32 No.1973935

    No DMA? Does it really matter with the current multi-GHz CPUs?
    >> Anonymous 08/04/08(Mon)19:36 No.1973961
         File :1217892988.png-(19 KB, 640x480, Untitled.png)
    19 KB

    Gave up on the VirtualBox install and took up your suggestion.
    I guess I'll just be playing around with the Live Cd for now.
    Looks awesome so far.
    >> Anonymous 08/04/08(Mon)19:38 No.1973977
    Anyone have their base install up and needs help setting up networking, automatic networking on bootup, software updating, software installation, recommended software packages, basics of using rio acme or rc?

    I think that by the middle of the week, we should be ready to start bringing the basics of the grid online, im reading the man pages and I think it can all be done with just a few commands, not that they could be bothered to provide a simple how-to instead of overly technical manpages.
    >> Anonymous 08/04/08(Mon)19:40 No.1973988
    Plan 9 has a REALLY shitty scheduler.
    Whenever I run a CPU intensive task, everything else becomes periodicially unresponsive.
    >> Anonymous 08/04/08(Mon)19:41 No.1973991
    This grid thing
    what exactly will it do
    >> Anonymous 08/04/08(Mon)19:41 No.1973995
    Are you running it in Qemu?
    If so, found your problem. Qemu is a fantastic technology and everything, but it can be a pile of shit at times.
    >> Anonymous 08/04/08(Mon)19:41 No.1974000

    once we get the grid up, the live cd will be all anyone needs, because plan 9 is designed to absorb computing resources on bootup and provide all services. for the moment though, working with the live cd and learning the interface a bit is great:

    PROTIP: acme is the shit. acme is the weird thing with all the different 'panels' and it can do everything (see earlier posts.)

    it takes quite awhile to get used to how the mouse buttons work in different situations, how the window manager works, all that stuff. its all very different and it seems horribly awkward at first but it gradually starts making more and more sense...

    in acme, assuming standard mouse mappings, button on the right = look at, middle button = do. so just click with the middle button on say 'new' and watch it pop up a new mini pane for you. find the /bin directory and you can execute commands by middle clicking on them! try spam middle clicking on the 'fortune' command, thats always fun.

    you just type a / anywhere and right click on it to open a new root window, then right click to open a folder...try looking in /386/bin/games and click on something!
    >> Anonymous 08/04/08(Mon)19:44 No.1974011

    plan 9 has tools for managing processes, the default user is just setup to let people play with stuff, the os is designed for managing distributed network resources and the experience of using it as a 'desktop' is interesting but god knows, its basically the worlds shittiest linux distro from another dimension until you start networking with it. acme is a true 'killer app' though, at least.
    >> Anonymous 08/04/08(Mon)19:46 No.1974021

    Basically, allow us to link up our plan 9 virtual machines into a single giant OS that allows us to not only share files and communicate, but also run processes on different CPUs and create 'plumbing' systems that do things like automatically creating a giant distributed 4chan archive shared between all our machines.
    >> Anonymous 08/04/08(Mon)19:52 No.1974056
    We need to do this to create a giant network of porn and various warez.
    Its required.
    >> Anonymous 08/04/08(Mon)19:54 No.1974065
    Fuck fuck fuck
    How long did distcopy take for most people?
    For the hour its been running its got 2%
    >> Anonymous 08/04/08(Mon)19:54 No.1974068
    To start getting a sense for how plan 9 'works' checkout two important files the system calls at boot:



    these basically determine the environment you start out in.
    >> Anonymous 08/04/08(Mon)19:55 No.1974078
    Took me about an hour.
    Kqemu is working for me though, are you using it?
    >> Anonymous 08/04/08(Mon)19:55 No.1974079

    not NEARLY that long. For me the install takes about 1-2 hrs or so. I've heard reports that the 10 hr+ installs may actually work, but you might want to start downloading another virtualization solution in the background.
    >> Anonymous 08/04/08(Mon)19:57 No.1974089
    Im on vbox.
    Isnt qemu for linux?
    >> Anonymous 08/04/08(Mon)19:59 No.1974105
    nice work everyone!
    most interesting thread /g/ has ever seen

    hope you manage to make p9 into something special
    >> Anonymous 08/04/08(Mon)20:00 No.1974110
    We are in desperate need of a good windows recommendation and tutorial. qemu in linux is basically flawless and idiot-proof so far as providing a solid emulation platform. What works best in windows? Who is using plan9 in windows and didnt have any install issues, either errors or incredibly long delays? Please describe your setup, including version of windows and any changes to relevant defaults in the VM or during the install process.


    was installing with VMware, ran into issues, then found a fix by changing the SCSI id of the cdrom in the virtual machine or something? does vmware work well if you do that fix?
    >> Anonymous 08/04/08(Mon)20:00 No.1974114

    I think there is a version for both, although I've heard the linux version is a bit 'better'.
    >> Anonymous 08/04/08(Mon)20:02 No.1974126
    Well Qemu apparntly doesnt support dma anyways
    >> Anonymous 08/04/08(Mon)20:05 No.1974144

    I dunno if this 'DMA' thing everyone is talking about is the whole story on this -- lets just focus on what WORKS -- is anyone using qemu in windows with good results? its great in linux even without the kqemu module, still looking for the recommended windows plan 9 virtualization platform. also please mention if you are using xp, vista, and 32 or 64 bit.
    >> Anonymous 08/04/08(Mon)20:06 No.1974154
    running xp w/ q6600 @ 3.2ghz, 2gb ram.
    Virtualbox is using 100% of one core
    2% after two hours
    Do not recommend
    >> Anonymous 08/04/08(Mon)20:14 No.1974193
    Has anyone tried VirtualPC?

    Grrr, I know multiple people have reported that they had plan 9 running well under windows emulation but didnt provide real specifics...maybe ill try to grep the threads I have saved.
    >> Anonymous 08/04/08(Mon)20:18 No.1974221
    a lot of googling is leading me to believe that qemu may be the best solution for windows as well as for linux.

    Can we get a confirmation on a successful windows plan 9 install with qemu?

    dammit, I think all the people running plan 9 are too busy fucking around with shit to check the thread...
    >> Anonymous 08/04/08(Mon)20:23 No.1974263
         File :1217895826.png-(45 KB, 1024x768, whenyouseeit.png)
    45 KB
    Ok, I think I have definitive proof that this OS was literally MADE FOR US.

    Not kidding. Prepare to shit bricks.

    in b4 zoom.
    >> Anonymous 08/04/08(Mon)20:30 No.1974295
         File :1217896224.jpg-(40 KB, 1136x126, bricks.jpg)
    40 KB

    >> Anonymous 08/04/08(Mon)20:41 No.1974346
    Total time:
    1 hour, 50 minutes.
    Install percent:

    fuck you virtualbox
    >> Anonymous 08/04/08(Mon)20:43 No.1974352
    Install QEMU + KQEMU.
    >> Anonymous 08/04/08(Mon)20:44 No.1974360

    Are you confirming qemu as a good WINDOWS solution? You have installed under vista or xp?
    >> Anonymous 08/04/08(Mon)20:45 No.1974373
    I've used it under Win2k without problems.
    >> Anonymous 08/04/08(Mon)20:46 No.1974376
    I cant figure out qemu.
    It opens that command-line esque window, and i try and create a disk with -img etc. and it just says "-IMG NOT RECOGNIZIEDIED"
    >> Anonymous 08/04/08(Mon)20:54 No.1974425
    You added an unnecessary space.
    It's "qemu-img" not "qemu -img"
    >> Anonymous 08/04/08(Mon)20:54 No.1974427
    Reverting my former statement, VMWare isn't so good on OS X. Trying with Parallels.
    >> Anonymous 08/04/08(Mon)20:55 No.1974440

    If you can write down the exact commands so people could cut and paste, that would be a fine service to your fellow anons. If its like it is in linux, its just a few commands.
    >> Anonymous 08/04/08(Mon)20:56 No.1974442
         File :1217897767.jpg-(70 KB, 654x495, lskd.jpg)
    70 KB
    >> Anonymous 08/04/08(Mon)20:58 No.1974458
    sh: qemu-img: command not found
    >> Anonymous 08/04/08(Mon)21:00 No.1974471
    GOOD NEWS for anyone struggling with installation:

    Once you get your machine up and connected to the network, getting the cluster services up is very, very easy. Basically, its a one-line command on each machine, plus dealing with any necessary firewall+router issues. Each machine basically just does:

    EXPORT (options) WhatImSharing
    IMPORT (options) WhatOthersAreSharing

    And BAM! there you are. Of course, figuring out those options is gonna take a bit more research, but man import has some nice simple examples for common services. What we are doing initially shoudl actually be even SIMPLER than the examples they give, because to begin with we just want to get basic filesharing up -- but in plan 9, 'basic filesharing' does about 10,000 times as much as in any other os, because the files...the files...are EVERYTHING
    >> Anonymous 08/04/08(Mon)21:01 No.1974473
    It has been a while since I've used QEMU in Windows, but IIRC, it's exactly the same as the Linux version.
    These are the commands I used to install Plan 9 on QEMU in Gentoo Linux.

    To create an 8GB QCOW image:
    qemu-img create -f qcow plan9.qcow 8G
    Booting from ISO image for installation:
    qemu -hda plan9.qcow -cdrom plan9.iso -net nic -net user -boot d
    Booting from QCOW image:
    qemu -hda plan9.qcow -net nic -net user -boot c
    >> Anonymous 08/04/08(Mon)21:02 No.1974485

    hey, we can maybe fix that! you have the kernel running and a shell at least: try typing this:

    aux/vga -m vesa -p

    and see if it says anything. or you could just directly try this:

    aux/vga -m vesa -l 640x480x8

    then try starting rio
    >> Anonymous 08/04/08(Mon)21:03 No.1974492
    sh: qemu-img: command not found
    >> Anonymous 08/04/08(Mon)21:03 No.1974493

    Yup thats basically exactly the same, on linux i didnt add those net options, id ahve to check man qemu to find out if there is actually anything different about the networking between linux-with-defaults and windows with those options you gave. but thats basically identical, so we have an almost universal how-to.
    >> Anonymous 08/04/08(Mon)21:04 No.1974500
    Total elapsed time:
    2 hours
    Total percent complete:
    Winxp Pro, Sp3
    >> Anonymous 08/04/08(Mon)21:04 No.1974505
    Then qemu-img isn't in your PATH.
    Fix it.
    >> Anonymous 08/04/08(Mon)21:05 No.1974513
    I just downloaded this thing, I dont even know what the hell Im doing.
    >> Anonymous 08/04/08(Mon)21:06 No.1974525
    If the guy who posted several times ending at:


    is to be believed (and why not) then there is a simple fix to get things working in VMware just by switching scsi to cd-rom -- apparently this information is from the wiki.
    >> Anonymous 08/04/08(Mon)21:09 No.1974551
    In Windows, you need to be in the same directory as the executables. This is basic knowledge.
    >> Anonymous 08/04/08(Mon)21:09 No.1974552
    Total Elapsed Time:
    2 hours, 3 minutes
    Total percent complete:
    WinXP Pro, sp3

    >> Anonymous 08/04/08(Mon)21:10 No.1974556
    I downloaded the .rar, extracted it all into its own little folder, and ran the .bat
    What the fuck am I doing wrong
    >> Anonymous 08/04/08(Mon)21:13 No.1974576

    I think you could probably get ubuntu installed and qemu+plan 9 on top of it before that vbox install is gonna finish...
    >> Anonymous 08/04/08(Mon)21:14 No.1974584
    You can't just run the batch file.
    You need to edit its contents first.
    >> Anonymous 08/04/08(Mon)21:14 No.1974585
    Fuck it
    Im gunna do that.
    I'm gunna put ubuntu into a vbox, then run qemu under that vbox.
    >> Anonymous 08/04/08(Mon)21:16 No.1974593
    What do I edit them to?
    >> Anonymous 08/04/08(Mon)21:16 No.1974596

    term% aux/vga -m vesa -p
    aux/vga: '/bin/aux/vga' does not exist

    gonna try qemu in windows now
    >> Anonymous 08/04/08(Mon)21:16 No.1974598
         File :1217899003.png-(137 KB, 600x331, 600px-ReactOS_logo.svg.png)
    137 KB
    Plan 9:
    The ReactOS of linux
    >> Anonymous 08/04/08(Mon)21:19 No.1974613
    AHA! I found this, from near the end of the first nights thread:


    - QEMU is a bitch to run on Windows. Use the old 0.9.0 version, not the 0.9.1 one.

    so...i dunno...right now the windows scene as i understand it is:

    virtualbox: insanely slow install, usable for Live cd exploration -- and the live cd is all you will need, ONCE WE HAVE THE GRID UP

    vmware: has some kind of glitch but may be fixable by changing cd-rom to scsi

    qemu: works ok, at least the 0.9.0 version but kind of a bitch to use

    virtual pc: seems to have graphics issues, did the guy who posted the pic try the graphics commands suggested?

    parallels for windows: anyone tried this? they have a free trial version download
    >> Anonymous 08/04/08(Mon)21:21 No.1974625

    I tried FreeBSD inside a virtualbox inside solaris inside a virtualbox running on Ubuntu and it ALMOST worked, but it froze at the exact second the virtual machine tried to capture the mouse, always

    maybe qemu can run inside virtualboxed ubuntu though? the qemu solution for plan 9 in linux is so damn easy its sickening, i feel bad for all the windows people struggling while we perfect an install setup
    >> Anonymous 08/04/08(Mon)21:22 No.1974633
         File :1217899322.jpg-(173 KB, 1271x991, untitled.jpg)
    173 KB
    And you all laughed when I got a quad core.
    >> Anonymous 08/04/08(Mon)21:23 No.1974641
    qemu-img create -f qcow "C:/PATH/TO/QCOW/IMAGE" 4G

    qemu -hda "C:/PATH/TO/QCOW/IMAGE" -cdrom "C:/PATH/TO/ISO/IMAGE" -net nic -net user -boot d

    qemu -hda "C:/PATH/TO/QCOW/IMAGE" -net nic -net user -boot c
    >> Anonymous 08/04/08(Mon)21:23 No.1974643
    >> Anonymous 08/04/08(Mon)21:25 No.1974649
    Which do you download for windows?
    parallels I mean
    >> Anonymous 08/04/08(Mon)21:28 No.1974665

    hmm, i hope all that text in the background of the install process isnt as bad as it looks, those look suspiciously like error messages to me, somehow

    0xdeaddead is a kind of scary looking hex address to see repeated so much...
    >> Anonymous 08/04/08(Mon)21:28 No.1974668
    do I make new bats with those contents, then run those?
    >> Anonymous 08/04/08(Mon)21:28 No.1974672

    QEMU took for-fucking-ever to install

    VMWare installed it, but it wouldn't boot -- google around and you'll see the plan 9 team is pissed that VMWare won't share any information to allow them to get it to work on their shit

    Paralells, dunno.

    Virtual PC, dunno.

    i dual-boot Ubuntu and Windows, and it worked flawlessly in UBANTO with QEmu.
    >> Anonymous 08/04/08(Mon)21:29 No.1974675
    It appears all the time for some reason.
    could be why its going so slow.
    HOLY FUCK 6%
    >> Anonymous 08/04/08(Mon)21:29 No.1974676


    has a link to a windows version i think
    >> Anonymous 08/04/08(Mon)21:31 No.1974692
    >> Anonymous 08/04/08(Mon)21:34 No.1974715
    More good news, at least for qemu users: from looking at the qemu options, they even have special networking options for connecting multiple virtual machines which would provide another layer of security for the project. not that plan 9 gets targeted by a lot of griefers, i dont think...
    >> Anonymous 08/04/08(Mon)21:35 No.1974725

    hopefully not quite as much forever as the virtualbox users are seeing? do we have vbox users on the other side of their infinite install to confirm that its not gonna be 14 hours of waiting for a terminal of random gibberish and a system freeze?
    >> Anonymous 08/04/08(Mon)21:36 No.1974729
    anyone think Plan 9 would be worth installing on a laptop?

    would it work?

    OSX86 does..
    >> Anonymous 08/04/08(Mon)21:38 No.1974743
    >QEMU took for-fucking-ever to install
    You didn't install KQEMU, did you?
    >> Anonymous 08/04/08(Mon)21:38 No.1974749
    Plan 9 has ludicrously low requirements, so it would probably work wonders for battery life.
    And if it works with linux, you can port the wireless drivers.

    With a bit of work, yes.
    Also, vbox is at 7%! MOVING LIKE A TRAIN
    Should I just kill the vbox plan 9, keep the vbox ubuntu -> qemu plan 9 and run a parrallels and vmware instead?
    >> Anonymous 08/04/08(Mon)21:41 No.1974768

    It's hard to say, we are the brave pioneers of this. Seriously everyone participating in this is doing real work that's actually gonna accomplish something -- because what plan 9 is lacking is a decent userbase of testers and some midlevel people with interest to help with debugging and maintainership and providing a community to get people up to speed.

    we could seriously become the pied pipers of true distributed computing, leapfrogging crappy ajax web 2.0 shit to go directly to web /9/.001
    >> Anonymous 08/04/08(Mon)21:41 No.1974771
    You people are fucking ridiculous.

    Why is this not on ED? We need to document our efforts.
    >> Anonymous 08/04/08(Mon)21:43 No.1974782

    drivers don't work with lunix, and i wouldn't be using it as a main OS. my laptop's just a vanilla intel machine (plan 9 wouldn't work on my AMD box) so I figure it's worth a shot.

    has anyone who's installed it on native hardware seen if it works with Broadcom 440x ethernet? i've googled but I haven't found much.
    >> Anonymous 08/04/08(Mon)21:45 No.1974801
    Nobody really knows what works and what doesnt.

    But fuck
    it just goes so slow
    I dont think its worth running through vbox
    >> Anonymous 08/04/08(Mon)21:45 No.1974802
    Windows experiences:

    on vista(home):
    virtualbox: slow as fuck, error? messages bleed through graphics.
    virtual pc 2007: installed fine, reboot, i/o errors, unbootable
    parallels: wouldn't even boot the iso

    windows xp (work):
    virtual pc 2004: installs ok, takes a long time for the filesystem. boots, but has login errors and rio won't start. see >>1974442
    qemu: in progress, filesystem taking a long time.(MUCH slower cpu at work, e8400 vs athlon xp 2600+)
    >> Anonymous 08/04/08(Mon)21:50 No.1974835


    Trolling or not, just fucking die. Please.
    >> Anonymous 08/04/08(Mon)21:52 No.1974841

    thanks very much for the reports. Its really seeming like qemu is the only hope, and i understand it can be difficult software to use. the advantage though is that if qemu is our standardized solution across both platforms we can get a good how to done and maybe even proved a downloadable script to help people.

    theres still that earlier repoort of a vmware install that seemed bad but was saved by a cd rom scsis reconfiguration -- and also people say that there is a vmware plan 9 preinstalled image? anyone checked for that?
    >> Anonymous 08/04/08(Mon)21:56 No.1974866
    Im killing my attempt at qemu through ubuntu on vbox because I dont know what the fuck I'm doing

    Gunna try vmware and parrallels, and kill my plan 9 on vbox since its going so ungodly slow.

    Plan 9 runs fine in vbox as a livecd however
    >> Anonymous 08/04/08(Mon)22:01 No.1974895
    Anybody wanna explain how to work vmware on windows?
    >> Anonymous 08/04/08(Mon)22:02 No.1974898

    Try using the CD as a 'live' cd, by choosing the 'boot plan 9' option without installing. This gives you a working environment -- and someone ought to figure out how to mount up a ram disk so you can install stuff to your live session. p9 can do it, definitely. more IMPORTANTLY:

    once the grid is up, the cd will be ALL you need -- you dont need to have p9 on your hard drive to use it fully and join the grid! THATS THE WHOLE POINT OF THE OS!

    If we actually knew anything at all about what we were doing, we would ALREADY have this going on -- but nobody has yet found the magical 2 lines that it takes (+router config) to mount remote file systems.

    man import
    man exportfs

    basically tell you how to do it...someone smart with man pages able to come up with the exact terminal commands?
    >> Anonymous 08/04/08(Mon)22:04 No.1974909
    It would be helpful if somebody could get all those pages into a txt or a doc or something outside of plan9 so they dont have to go through the hassle of installing it.

    Also, vmware couldnt read iso.
    >> Anonymous 08/04/08(Mon)22:06 No.1974922
    i ran as a live cd on vbox on vista32 and it ran like crap.
    virtual pc 2007 ran the live cd perfectly.
    >> Anonymous 08/04/08(Mon)22:08 No.1974938
    >parallels couldnt read the iso
    >> Anonymous 08/04/08(Mon)22:11 No.1974959

    those pages are available via the online manpages and documentation from the main plan 9 site. im sure the exact needed commands to bring up a remote node on our grid are all of 3-4 clicks away from the front page...

    the man pages browser has been flaky however, lol. and why not? its hosted on plan 9 after all...
    >> Anonymous 08/04/08(Mon)22:22 No.1975018

    >> Anonymous 08/04/08(Mon)22:50 No.1975180

    oops, not all platforms, forgot about mac os x, I think we have parallels for mac confirmed as being ok? the plan 9 wiki seems to think so and i believe it was reported running on os x under it. vmware fusion for os x we got a 'its good' followed by 'i take it back, its bad' so probably try parallels for os x.

    qemu for linux and windows, strange rumor about qemu 0.9.0 being better than 0.9.1, dunno -- but we still need a qemu step by step on windows, i hear its more difficult.
    >> Anonymous 08/04/08(Mon)23:09 No.1975304
    I've googled, but I'm getting conflicting results for whether plan9 works on eee pc. So, uh, anyone tried it yet?
    >> Anonymous 08/04/08(Mon)23:13 No.1975335

    in emulation? or natively? plan 9 can be really light, if you can run qemu and play with your ram you might be able to do it
    >> Anonymous 08/04/08(Mon)23:15 No.1975353
    qemu(on windows at least) apparently doesn't support dma as it was taking FOREVER to install the file system.
    im just gonna use the live-cd and save states since its not really important anyway.
    >> Anonymous 08/04/08(Mon)23:28 No.1975434
         File :1217906934.png-(142 KB, 1024x768, why9.png)
    142 KB
    1-2 hrs for an install is about typical for me on qemu -- a few hrs isnt really that bad, as long as the system works. can someone please write out a very brief step-by-step recipe for qemu install on windows? once ONE PERSON gets it nailed down it gets so much easier

    anyone with an up-and-running setup need help with networking, software installation?

    Delete Post [File Only]
    Style [Yotsuba | Yotsuba B | Futaba | Burichan]
    Watched Threads
    PosterThread Title
    No Threads Watched